summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMarko Myllynen <myllynen@redhat.com>2011-09-23 10:03:10 +0300
committerStephen Gallagher <sgallagh@redhat.com>2011-09-28 09:06:57 -0400
commitf5b6f977d4144c28e9c66f3f1c9d634d595d1117 (patch)
tree47b324773bd4dd7e4482317f0c550878b07ab095 /configure.ac
parent4a6a5421113ab662a665c62ed6a24b61a5a36950 (diff)
downloadsssd-f5b6f977d4144c28e9c66f3f1c9d634d595d1117.tar.gz
sssd-f5b6f977d4144c28e9c66f3f1c9d634d595d1117.tar.xz
sssd-f5b6f977d4144c28e9c66f3f1c9d634d595d1117.zip
Unbreak ./configure
./configure at least from 1.5.13 is failing on Ubuntu Oneiric. The node ``Conditionals'' of automake manual states: Note that you must arrange for _every_ `AM_CONDITIONAL' to be invoked every time `configure' is run. If `AM_CONDITIONAL' is run conditionally (e.g., in a shell `if' statement), then the result will confuse `automake'. So the trick is to run AM_CONDITIONAL unconditionally.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 958fa1436..19ee498a4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -144,8 +144,8 @@ if test x$HAVE_MANPAGES != x; then
[http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl],
[Docbook XSL templates])
AC_CHECK_PROG([PO4A],[po4a],[po4a],[no])
- AM_CONDITIONAL([HAVE_PO4A], [test "x$PO4A" != "xno"])
fi
+AM_CONDITIONAL([HAVE_PO4A], [test "x$PO4A" != "xno"])
if test x$HAVE_PYTHON_BINDINGS != x; then
AM_PATH_PYTHON([2.4])