summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorStephen Gallagher <sgallagh@redhat.com>2010-01-18 09:37:44 -0500
committerStephen Gallagher <sgallagh@redhat.com>2010-01-21 15:02:15 -0500
commit1183d29d87c5c7439cf2364b7d7324d4a13b6e35 (patch)
treeda6a0adfc20c82f915c43c93ba0c83809bd296f8 /configure.ac
parentee359fe1384507fed6c2274e7bfe81d288de4542 (diff)
downloadsssd-1183d29d87c5c7439cf2364b7d7324d4a13b6e35.tar.gz
sssd-1183d29d87c5c7439cf2364b7d7324d4a13b6e35.tar.xz
sssd-1183d29d87c5c7439cf2364b7d7324d4a13b6e35.zip
Add 'prerelease-srpms' target to Makefile
This target is available only if building from a git checkout. It will automatically populate the PRERELEASE_VERSION in version.m4 with the current datestamp and git commit id for creating an SRPM.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d0785ad78..7f329676d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -13,5 +13,7 @@ AC_CONFIG_SUBDIRS([replace common server sss_client])
AC_SUBST([PRERELEASE_VERSION],
PRERELEASE_VERSION_NUMBER)
+AM_CONDITIONAL([GIT_CHECKOUT], [git log -1 &>/dev/null])
+
AC_CONFIG_FILES([Makefile contrib/sssd.spec])
AC_OUTPUT