summaryrefslogtreecommitdiffstats
path: root/common/path_utils/configure.ac
diff options
context:
space:
mode:
authorJohn Dennis <jdennis@jdennis.(none)>2009-07-14 11:25:37 -0400
committerStephen Gallagher <sgallagh@redhat.com>2009-07-15 08:56:51 -0400
commitdf8b16d7d55d97001ed71f629fc21511ec9f8d3b (patch)
tree601fc66ee7526f2035306e256265b5d9a0fab038 /common/path_utils/configure.ac
parent7f5e857a11f932c247b5a96d0d86768226ba2e96 (diff)
downloadsssd-df8b16d7d55d97001ed71f629fc21511ec9f8d3b.tar.gz
sssd-df8b16d7d55d97001ed71f629fc21511ec9f8d3b.tar.xz
sssd-df8b16d7d55d97001ed71f629fc21511ec9f8d3b.zip
add path_utils filesystem path manipulation utility functions
remove trace macro, not needed modifications to satisfy Stephen's checkin review correct spelling of PATH_UTILS_ERROR_NOT_FULLY_NORMALIZED add checks for truncation, return error add checks for getcwd errors modify (dst >= dst_end) test to be (dst > dst_end) remove all use of tabs remove all trailing whitespace add missing truncation check after strncpy() Fix path_utils.pc Also correct a minor typo.
Diffstat (limited to 'common/path_utils/configure.ac')
-rw-r--r--common/path_utils/configure.ac18
1 files changed, 18 insertions, 0 deletions
diff --git a/common/path_utils/configure.ac b/common/path_utils/configure.ac
new file mode 100644
index 000000000..9207a075b
--- /dev/null
+++ b/common/path_utils/configure.ac
@@ -0,0 +1,18 @@
+AC_INIT([path_utils], [0.1], [jdennis@redhat.com])
+AC_CONFIG_SRCDIR([path_utils.c])
+AC_CONFIG_AUX_DIR([build])
+AM_INIT_AUTOMAKE([-Wall -Werror foreign])
+AC_PROG_CC
+AC_PROG_LIBTOOL
+AC_CONFIG_MACRO_DIR([m4])
+AC_PROG_INSTALL
+
+AM_CONDITIONAL([HAVE_GCC], [test "$ac_cv_prog_gcc" = yes])
+
+m4_pattern_allow([AM_SILENT_RULES])
+AM_SILENT_RULES
+
+AC_CONFIG_HEADERS([config.h])
+
+AC_CONFIG_FILES([Makefile path_utils.pc])
+AC_OUTPUT