summaryrefslogtreecommitdiffstats
path: root/common/path_utils/configure.ac
diff options
context:
space:
mode:
authorJakub Hrozek <jhrozek@redhat.com>2010-03-16 09:17:02 +0100
committerStephen Gallagher <sgallagh@redhat.com>2010-03-25 12:14:14 -0400
commit75ad7dcdeb71126f1bd4bfc652c29101dd386a1b (patch)
treecfe414facf2d1d1af3cab4a209e87a199d714725 /common/path_utils/configure.ac
parent379700b260c211a9b17be1ab37bc37f61a0d1b56 (diff)
downloadsssd-75ad7dcdeb71126f1bd4bfc652c29101dd386a1b.tar.gz
sssd-75ad7dcdeb71126f1bd4bfc652c29101dd386a1b.tar.xz
sssd-75ad7dcdeb71126f1bd4bfc652c29101dd386a1b.zip
Unit tests for path_utils
Fixes: #81
Diffstat (limited to 'common/path_utils/configure.ac')
-rw-r--r--common/path_utils/configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/common/path_utils/configure.ac b/common/path_utils/configure.ac
index 87dd6150a..7978b40ef 100644
--- a/common/path_utils/configure.ac
+++ b/common/path_utils/configure.ac
@@ -9,6 +9,12 @@ AC_PROG_INSTALL
AM_CONDITIONAL([HAVE_GCC], [test "$ac_cv_prog_gcc" = yes])
+PKG_CHECK_MODULES([CHECK], [check >= 0.9.5], [have_check=1], [have_check=])
+if test x$have_check = x; then
+ AC_MSG_WARN([Without the 'CHECK' libraries, you will be unable to run all tests in the 'make check' suite])
+fi
+AM_CONDITIONAL([HAVE_CHECK], [test x$have_check != x])
+
m4_pattern_allow([AM_SILENT_RULES])
AM_SILENT_RULES