summaryrefslogtreecommitdiffstats
path: root/common/path_utils/Makefile.am
diff options
context:
space:
mode:
authorJakub Hrozek <jhrozek@redhat.com>2010-03-16 09:17:02 +0100
committerStephen Gallagher <sgallagh@redhat.com>2010-03-25 15:58:34 -0400
commit3f654111bcd9822a6387a7cec496d7532646dc5b (patch)
tree915feaab145d8e6e88a34f8776b706a77defd4d3 /common/path_utils/Makefile.am
parentf98e9063f4617cd3b9066940e8e39c09a6ed544b (diff)
downloadsssd-3f654111bcd9822a6387a7cec496d7532646dc5b.tar.gz
sssd-3f654111bcd9822a6387a7cec496d7532646dc5b.tar.xz
sssd-3f654111bcd9822a6387a7cec496d7532646dc5b.zip
Unit tests for path_utils
Fixes: #81
Diffstat (limited to 'common/path_utils/Makefile.am')
-rw-r--r--common/path_utils/Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/common/path_utils/Makefile.am b/common/path_utils/Makefile.am
index 8539ffd12..45910a929 100644
--- a/common/path_utils/Makefile.am
+++ b/common/path_utils/Makefile.am
@@ -19,4 +19,18 @@ libpath_utils_la_SOURCES = path_utils.c
libpath_utils_la_LDFLAGS = \
-version-info 1:0:0
+if HAVE_CHECK
+ check_PROGRAMS = path_utils_ut
+endif
+
+path_utils_ut_SOURCES = \
+ path_utils_ut.c
+path_utils_ut_CFLAGS = \
+ $(AM_CFLAGS) \
+ $(CHECK_CFLAGS)
+path_utils_ut_LDADD = \
+ $(CHECK_LIBS) \
+ libpath_utils.la
+TESTS = $(check_PROGRAMS)
+
tests: all $(check_PROGRAMS)