summaryrefslogtreecommitdiffstats
path: root/common/path_utils/Makefile.am
diff options
context:
space:
mode:
authorStephen Gallagher <sgallagh@redhat.com>2010-01-22 14:07:51 -0500
committerStephen Gallagher <sgallagh@redhat.com>2010-02-03 10:35:16 -0500
commit04960af31ba8e532dd463ae7fe07c89d402430b6 (patch)
treec79beaed6ed766f9617b74e9c9631374b6504f66 /common/path_utils/Makefile.am
parent8e09e179f66df39bcef07cbc61a22d349ed304f4 (diff)
downloadsssd-04960af31ba8e532dd463ae7fe07c89d402430b6.tar.gz
sssd-04960af31ba8e532dd463ae7fe07c89d402430b6.tar.xz
sssd-04960af31ba8e532dd463ae7fe07c89d402430b6.zip
Split off libpath_utils into a shared library
Diffstat (limited to 'common/path_utils/Makefile.am')
-rw-r--r--common/path_utils/Makefile.am16
1 files changed, 9 insertions, 7 deletions
diff --git a/common/path_utils/Makefile.am b/common/path_utils/Makefile.am
index b738c3e69..8539ffd12 100644
--- a/common/path_utils/Makefile.am
+++ b/common/path_utils/Makefile.am
@@ -8,13 +8,15 @@ endif
ACLOCAL_AMFLAGS = -I m4
pkgconfigdir = $(libdir)/pkgconfig
-dist_noinst_DATA = \
- path_utils.pc \
- m4
+dist_pkgconfig_DATA = path_utils.pc
-noinst_LTLIBRARIES = libpath_utils.la
-libpath_utils_la_SOURCES = \
- path_utils.c \
- path_utils.h
+dist_include_HEADERS = path_utils.h
+
+dist_noinst_DATA = m4
+
+lib_LTLIBRARIES = libpath_utils.la
+libpath_utils_la_SOURCES = path_utils.c
+libpath_utils_la_LDFLAGS = \
+ -version-info 1:0:0
tests: all $(check_PROGRAMS)