summaryrefslogtreecommitdiffstats
path: root/common/path_utils/Makefile.am
diff options
context:
space:
mode:
authorJakub Hrozek <jhrozek@redhat.com>2010-03-16 09:17:02 +0100
committerStephen Gallagher <sgallagh@redhat.com>2010-03-25 12:14:14 -0400
commit75ad7dcdeb71126f1bd4bfc652c29101dd386a1b (patch)
treecfe414facf2d1d1af3cab4a209e87a199d714725 /common/path_utils/Makefile.am
parent379700b260c211a9b17be1ab37bc37f61a0d1b56 (diff)
downloadsssd-75ad7dcdeb71126f1bd4bfc652c29101dd386a1b.tar.gz
sssd-75ad7dcdeb71126f1bd4bfc652c29101dd386a1b.tar.xz
sssd-75ad7dcdeb71126f1bd4bfc652c29101dd386a1b.zip
Unit tests for path_utils
Fixes: #81
Diffstat (limited to 'common/path_utils/Makefile.am')
-rw-r--r--common/path_utils/Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/common/path_utils/Makefile.am b/common/path_utils/Makefile.am
index 8539ffd12..45910a929 100644
--- a/common/path_utils/Makefile.am
+++ b/common/path_utils/Makefile.am
@@ -19,4 +19,18 @@ libpath_utils_la_SOURCES = path_utils.c
libpath_utils_la_LDFLAGS = \
-version-info 1:0:0
+if HAVE_CHECK
+ check_PROGRAMS = path_utils_ut
+endif
+
+path_utils_ut_SOURCES = \
+ path_utils_ut.c
+path_utils_ut_CFLAGS = \
+ $(AM_CFLAGS) \
+ $(CHECK_CFLAGS)
+path_utils_ut_LDADD = \
+ $(CHECK_LIBS) \
+ libpath_utils.la
+TESTS = $(check_PROGRAMS)
+
tests: all $(check_PROGRAMS)