summaryrefslogtreecommitdiffstats
path: root/common/path_utils/Makefile.am
diff options
context:
space:
mode:
authorJakub Hrozek <jhrozek@redhat.com>2010-03-19 13:59:02 +0100
committerStephen Gallagher <sgallagh@redhat.com>2010-03-25 12:14:14 -0400
commit36f341109287f42f33a4ed3d25746741bdfb71f4 (patch)
treecb4eafe4059c0c4c9f522a3db4997b7119487601 /common/path_utils/Makefile.am
parent75ad7dcdeb71126f1bd4bfc652c29101dd386a1b (diff)
downloadsssd-36f341109287f42f33a4ed3d25746741bdfb71f4.tar.gz
sssd-36f341109287f42f33a4ed3d25746741bdfb71f4.tar.xz
sssd-36f341109287f42f33a4ed3d25746741bdfb71f4.zip
Generate doxygen documentation for path_utils
Diffstat (limited to 'common/path_utils/Makefile.am')
-rw-r--r--common/path_utils/Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/common/path_utils/Makefile.am b/common/path_utils/Makefile.am
index 45910a929..5cd797b70 100644
--- a/common/path_utils/Makefile.am
+++ b/common/path_utils/Makefile.am
@@ -7,6 +7,8 @@ endif
ACLOCAL_AMFLAGS = -I m4
+DOXYGEN = @DOXYGEN@
+
pkgconfigdir = $(libdir)/pkgconfig
dist_pkgconfig_DATA = path_utils.pc
@@ -34,3 +36,15 @@ path_utils_ut_LDADD = \
TESTS = $(check_PROGRAMS)
tests: all $(check_PROGRAMS)
+
+if HAVE_DOXYGEN
+docs:
+ rm -fR doc
+ mkdir -p doc
+ $(DOXYGEN) path_utils.cfg.doxy
+else
+docs:
+ @echo "Doxygen not installed, cannot generate documentation"
+ @exit 1
+endif
+