summaryrefslogtreecommitdiffstats
path: root/common/path_utils/Makefile.am
diff options
context:
space:
mode:
authorJohn Dennis <jdennis@jdennis.(none)>2009-07-14 11:25:37 -0400
committerStephen Gallagher <sgallagh@redhat.com>2009-07-15 08:56:51 -0400
commitdf8b16d7d55d97001ed71f629fc21511ec9f8d3b (patch)
tree601fc66ee7526f2035306e256265b5d9a0fab038 /common/path_utils/Makefile.am
parent7f5e857a11f932c247b5a96d0d86768226ba2e96 (diff)
downloadsssd-df8b16d7d55d97001ed71f629fc21511ec9f8d3b.tar.gz
sssd-df8b16d7d55d97001ed71f629fc21511ec9f8d3b.tar.xz
sssd-df8b16d7d55d97001ed71f629fc21511ec9f8d3b.zip
add path_utils filesystem path manipulation utility functions
remove trace macro, not needed modifications to satisfy Stephen's checkin review correct spelling of PATH_UTILS_ERROR_NOT_FULLY_NORMALIZED add checks for truncation, return error add checks for getcwd errors modify (dst >= dst_end) test to be (dst > dst_end) remove all use of tabs remove all trailing whitespace add missing truncation check after strncpy() Fix path_utils.pc Also correct a minor typo.
Diffstat (limited to 'common/path_utils/Makefile.am')
-rw-r--r--common/path_utils/Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/common/path_utils/Makefile.am b/common/path_utils/Makefile.am
new file mode 100644
index 000000000..fdda791ca
--- /dev/null
+++ b/common/path_utils/Makefile.am
@@ -0,0 +1,17 @@
+AM_CFLAGS =
+if HAVE_GCC
+ AM_CFLAGS += \
+ -Wall -Wshadow -Wstrict-prototypes -Wpointer-arith -Wcast-qual \
+ -Wcast-align -Wwrite-strings
+endif
+
+ACLOCAL_AMFLAGS = -I m4
+
+pkgconfigdir = $(libdir)/pkgconfig
+dist_noinst_DATA = path_utils.pc
+
+noinst_LTLIBRARIES = libpath_utils.la
+libpath_utils_la_SOURCES = \
+ path_utils.c \
+ path_utils.h
+