summaryrefslogtreecommitdiffstats
path: root/common/ini/Makefile.am
diff options
context:
space:
mode:
authorDmitri Pal <dpal@redhat.com>2010-03-29 16:58:29 -0400
committerStephen Gallagher <sgallagh@redhat.com>2010-04-14 12:15:54 -0400
commite4956873b0ca4ec732e009f88be43549506f7819 (patch)
treeddef1a00bc399d5070487d05f9f30ba54706bbdb /common/ini/Makefile.am
parentd675db76493ab9dcf8ccb0422b1477b780df8bc3 (diff)
downloadsssd-e4956873b0ca4ec732e009f88be43549506f7819.tar.gz
sssd-e4956873b0ca4ec732e009f88be43549506f7819.tar.xz
sssd-e4956873b0ca4ec732e009f88be43549506f7819.zip
Adding metadata interface
This patch: 1) Adds the definition of the metadata interface to the header file. The functions that were exposed for no good reason are now hidden. 2) Previously exposed functions and their descriptions are removed from the public header and placed into the source code for now. 3) The function that reads the config file no longer tries to close file in case of error. 4) Lines collection is still passed in into the reading function but as a collection itself not as a pointer to it. 5) All the parts related to processing lines are currently ifdefed using HAVE_VALIDATION that is currently is not defined. This is done to disable creation of the lines collection utill it is actually needed. I did not want to blindly remove it though and loose already done work that will be useful in future. 6) Version of the library and interface is updated 7) New header and source modules are introduced to hold functions related to the meta data. They are mostly stubbed out. This is incomplete patch. It builds and make check runs. It is created just to simplify the review a bit.
Diffstat (limited to 'common/ini/Makefile.am')
-rw-r--r--common/ini/Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/common/ini/Makefile.am b/common/ini/Makefile.am
index af81a9f89..76205262d 100644
--- a/common/ini/Makefile.am
+++ b/common/ini/Makefile.am
@@ -33,12 +33,15 @@ dist_include_HEADERS = \
# Build library
lib_LTLIBRARIES = libini_config.la
libini_config_la_SOURCES = \
- ini_config.c
+ ini_config.c \
+ ini_metadata.c \
+ ini_metadata.h
+
libini_config_la_LIBADD = \
-L$(topbuilddir)/collection \
-lcollection
libini_config_la_LDFLAGS = \
- -version-info 1:0:0
+ -version-info 2:0:0
# Build unit test
check_PROGRAMS = ini_config_ut