summaryrefslogtreecommitdiffstats
path: root/common/ini/Makefile.am
diff options
context:
space:
mode:
authorStephen Gallagher <sgallagh@redhat.com>2009-05-21 09:03:01 -0400
committerSimo Sorce <ssorce@redhat.com>2009-05-26 09:10:45 -0400
commit419d4579bcb84a3b10d8b5048df2087a3f55544f (patch)
treee36310049957f423bc9afa0d9ec7a1f056ac3274 /common/ini/Makefile.am
parent23cb08ee2f1e3b597742281e475350039247d9d8 (diff)
downloadsssd-419d4579bcb84a3b10d8b5048df2087a3f55544f.tar.gz
sssd-419d4579bcb84a3b10d8b5048df2087a3f55544f.tar.xz
sssd-419d4579bcb84a3b10d8b5048df2087a3f55544f.zip
Clean up automake build to work on older versions of libtool
LT_INIT is supported only on Libtool >= 2.0, so I reverted it to using AC_PROG_LIBTOOL. Also reorganized how the common libraries were being built. Now they are treated as libtool convenience libraries instead of installable libraries (the --with-singlelib configure flag can still be used to generate a combined, installable DSO) I cleaned up the set of files being installed by automake, so the list of things we need to remove before packaging the RPM is now only the .la files associated with our own plugins.
Diffstat (limited to 'common/ini/Makefile.am')
-rw-r--r--common/ini/Makefile.am9
1 files changed, 5 insertions, 4 deletions
diff --git a/common/ini/Makefile.am b/common/ini/Makefile.am
index 7278136ec..03d891256 100644
--- a/common/ini/Makefile.am
+++ b/common/ini/Makefile.am
@@ -7,12 +7,13 @@ ACLOCAL_AMFLAGS = -I m4
# Set up the pkg-config file
pkgconfigdir = $(libdir)/pkgconfig
-pkgconfig_DATA = ini_config.pc
+dist_noinst_DATA = ini_config.pc
# Build library
-lib_LTLIBRARIES = libini_config.la
-libini_config_la_SOURCES = ini_config.c
-include_HEADERS = ini_config.h
+noinst_LTLIBRARIES = libini_config.la
+libini_config_la_SOURCES = \
+ ini_config.c \
+ ini_config.h
# Build unit test
noinst_PROGRAMS = ini_config_ut