summaryrefslogtreecommitdiffstats
path: root/common/elapi/configure.ac
diff options
context:
space:
mode:
authorDmitri Pal <dpal@redhat.com>2009-10-07 09:45:39 -0400
committerStephen Gallagher <sgallagh@redhat.com>2009-10-16 14:27:24 -0400
commit01bf2fcf57944104f9a774c8716950f397d666ce (patch)
tree7d20b82674596a0946a2b339f807cf84fc58c769 /common/elapi/configure.ac
parent82648b5af3cb5e68a48fe1e798ef48254ccbecb8 (diff)
downloadsssd-01bf2fcf57944104f9a774c8716950f397d666ce.tar.gz
sssd-01bf2fcf57944104f9a774c8716950f397d666ce.tar.xz
sssd-01bf2fcf57944104f9a774c8716950f397d666ce.zip
ELAPI Compatibility code for getifaddr()
Addreses ticket #94 Actually works pretty well. To try use --enable-compat when build ELAPI. It will use compatibility code instead of getifaddr(). The trick in the elapi_ioctl.h with memory allocation is taken from Stevens book.
Diffstat (limited to 'common/elapi/configure.ac')
-rw-r--r--common/elapi/configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/common/elapi/configure.ac b/common/elapi/configure.ac
index ad2ffceec..82be136df 100644
--- a/common/elapi/configure.ac
+++ b/common/elapi/configure.ac
@@ -14,6 +14,7 @@ AM_SILENT_RULES
AC_CONFIG_HEADERS([config.h])
+
# Enable trace build
AC_ARG_ENABLE([trace],
[AS_HELP_STRING([--enable-trace[=LEVEL]],[build with low level tracing enabled])],
@@ -21,12 +22,14 @@ AC_ARG_ENABLE([trace],
[trace_level="0"])
AS_IF([test ["$trace_level" -gt "0"] -a ["$trace_level" -lt "8"] ],[AC_SUBST([TRACE_VAR],["-DTRACE_LEVEL=$trace_level"])])
+
m4_include(conf_macros.m4)
WITH_CONFIG_DIR
WITH_CONFIG_APP_DIR
WITH_APP_NAME
WITH_APP_NAME_SIZE
+WITH_COMPAT
m4_include(def_macros.m4)