summaryrefslogtreecommitdiffstats
path: root/common/elapi/Makefile.am
diff options
context:
space:
mode:
authorDmitri Pal <dpal@redhat.com>2009-10-07 09:45:39 -0400
committerStephen Gallagher <sgallagh@redhat.com>2009-10-16 14:27:24 -0400
commit01bf2fcf57944104f9a774c8716950f397d666ce (patch)
tree7d20b82674596a0946a2b339f807cf84fc58c769 /common/elapi/Makefile.am
parent82648b5af3cb5e68a48fe1e798ef48254ccbecb8 (diff)
downloadsssd-01bf2fcf57944104f9a774c8716950f397d666ce.tar.gz
sssd-01bf2fcf57944104f9a774c8716950f397d666ce.tar.xz
sssd-01bf2fcf57944104f9a774c8716950f397d666ce.zip
ELAPI Compatibility code for getifaddr()
Addreses ticket #94 Actually works pretty well. To try use --enable-compat when build ELAPI. It will use compatibility code instead of getifaddr(). The trick in the elapi_ioctl.h with memory allocation is taken from Stevens book.
Diffstat (limited to 'common/elapi/Makefile.am')
-rw-r--r--common/elapi/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/common/elapi/Makefile.am b/common/elapi/Makefile.am
index 53f2c3eff..747a3883b 100644
--- a/common/elapi/Makefile.am
+++ b/common/elapi/Makefile.am
@@ -55,13 +55,17 @@ libelapi_la_SOURCES = \
elapi_resolve.c \
elapi_async.c \
elapi_subst.c \
+ elapi_ioctl.c \
elapi_event.h \
elapi_priv.h \
elapi_sink.h \
elapi_log.h \
elapi_async.h \
+ elapi_net.h \
+ elapi_ioctl.h \
elapi_fd.h \
elapi_tm.h \
+ elapi_defines.h \
elapi.h
libelapi_la_LIBADD = libprovider.la libelapibasic.la