summaryrefslogtreecommitdiffstats
path: root/common/dhash/Makefile.am
diff options
context:
space:
mode:
authorStephen Gallagher <sgallagh@redhat.com>2009-07-13 09:12:33 -0400
committerStephen Gallagher <sgallagh@redhat.com>2009-07-13 12:13:55 -0400
commit7f5e857a11f932c247b5a96d0d86768226ba2e96 (patch)
tree979dd585dbcc4d4405cf64b915ee944268d59712 /common/dhash/Makefile.am
parentc26fd1ebd626a01f9c56796c64f6824525d77085 (diff)
downloadsssd-7f5e857a11f932c247b5a96d0d86768226ba2e96.tar.gz
sssd-7f5e857a11f932c247b5a96d0d86768226ba2e96.tar.xz
sssd-7f5e857a11f932c247b5a96d0d86768226ba2e96.zip
Build all SSSD components with warnings enabled
Previously, only the SSSD server components were being built with compile-time warnings enabled. This patch will ensure that all components in common and sss_client are also built the same way.
Diffstat (limited to 'common/dhash/Makefile.am')
-rw-r--r--common/dhash/Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/common/dhash/Makefile.am b/common/dhash/Makefile.am
index 9037bf97c..b8d5ce6ff 100644
--- a/common/dhash/Makefile.am
+++ b/common/dhash/Makefile.am
@@ -1,4 +1,10 @@
-AM_CPPFLAGS = -Wall
+AM_CFLAGS =
+if HAVE_GCC
+ AM_CFLAGS += \
+ -Wall -Wshadow -Wstrict-prototypes -Wpointer-arith -Wcast-qual \
+ -Wcast-align -Wwrite-strings
+endif
+
ACLOCAL_AMFLAGS = -I m4
pkgconfigdir = $(libdir)/pkgconfig