summaryrefslogtreecommitdiffstats
path: root/common/configure.ac
diff options
context:
space:
mode:
authorDmitri Pal <dpal@redhat.com>2009-04-06 09:30:01 -0400
committerStephen Gallagher <sgallagh@redhat.com>2009-04-06 15:59:21 -0400
commitde6d6fb21bf367a94c7d292f2c3decd24cf42868 (patch)
tree3eb3a5347eb9b39ede80984a3b2caade1cfa40c4 /common/configure.ac
parent2ec952c6db27db1d5a21154e2683d1e862643ac8 (diff)
downloadsssd-de6d6fb21bf367a94c7d292f2c3decd24cf42868.tar.gz
sssd-de6d6fb21bf367a94c7d292f2c3decd24cf42868.tar.xz
sssd-de6d6fb21bf367a94c7d292f2c3decd24cf42868.zip
First commit of basic collection API.
Diffstat (limited to 'common/configure.ac')
-rw-r--r--common/configure.ac25
1 files changed, 25 insertions, 0 deletions
diff --git a/common/configure.ac b/common/configure.ac
new file mode 100644
index 000000000..83a2c1845
--- /dev/null
+++ b/common/configure.ac
@@ -0,0 +1,25 @@
+AC_INIT([elapi], [0.0], [dpal@redhat.com])
+AC_CONFIG_SRCDIR([collection/collection.c])
+AC_CONFIG_AUX_DIR([build])
+AM_INIT_AUTOMAKE([-Wall -Werror foreign])
+AC_PROG_CC
+AC_PROG_LIBTOOL
+AC_PROG_INSTALL
+
+AC_CONFIG_HEADERS([config.h])
+
+
+# Enable trace build
+AC_ARG_ENABLE([trace],
+ [AS_HELP_STRING([--enable-trace],[build with low level tracing enabled])],
+ [trace_level="$enableval"],
+ [trace_level="0"])
+AS_IF([test ["$trace_level" -gt "0"] -a ["$trace_level" -lt "8"] ],[AC_SUBST([TRACE_VAR],["-DTRACE_LEVEL=$trace_level"])])
+
+
+AC_CONFIG_FILES([Makefile collection/Makefile])
+AC_OUTPUT
+
+
+
+