summaryrefslogtreecommitdiffstats
path: root/common/configure.ac
diff options
context:
space:
mode:
authorStephen Gallagher <sgallagh@redhat.com>2009-05-12 11:51:20 -0400
committerSimo Sorce <ssorce@redhat.com>2009-05-14 11:34:04 -0400
commit798af224b66e25b694569f70e86262f7867917cf (patch)
tree80950d451cc75c99ad3cd8c5e07faa91ec34b1bc /common/configure.ac
parent24ad71529edd3ef6cfe7785d6c6e4f51d5cc42db (diff)
downloadsssd-798af224b66e25b694569f70e86262f7867917cf.tar.gz
sssd-798af224b66e25b694569f70e86262f7867917cf.tar.xz
sssd-798af224b66e25b694569f70e86262f7867917cf.zip
Enable modular build of common SSSD libraries
Allow configuration and build of individual SSSD utility libraries from their own subdirectories. Building all utilities is still possible recursively from the common root.
Diffstat (limited to 'common/configure.ac')
-rw-r--r--common/configure.ac11
1 files changed, 6 insertions, 5 deletions
diff --git a/common/configure.ac b/common/configure.ac
index 120d1034f..a5fa3d547 100644
--- a/common/configure.ac
+++ b/common/configure.ac
@@ -1,9 +1,10 @@
-AC_INIT([elapi], [0.0], [dpal@redhat.com])
-AC_CONFIG_SRCDIR([collection/collection.c])
+AC_INIT([sssd_libs], [0.3.3], [sgallagh@redhat.com])
+AC_CONFIG_SRCDIR([README])
AC_CONFIG_AUX_DIR([build])
AM_INIT_AUTOMAKE([-Wall -Werror foreign])
AC_PROG_CC
AC_PROG_LIBTOOL
+AC_CONFIG_MACRO_DIR([m4])
AC_PROG_INSTALL
AC_CONFIG_HEADERS([config.h])
@@ -18,10 +19,10 @@ AS_IF([test ["$trace_level" -gt "0"] -a ["$trace_level" -lt "8"] ],[AC_SUBST([TR
AC_CONFIG_FILES([Makefile
- collection/Makefile collection/collection.pc
- dhash/Makefile dhash/dhash.pc
- ini/Makefile ini/ini_config.pc
trace/Makefile])
+
+AC_CONFIG_SUBDIRS([collection dhash ini])
+
AC_OUTPUT