summaryrefslogtreecommitdiffstats
path: root/common/configure.ac
diff options
context:
space:
mode:
authorStephen Gallagher <sgallagh@redhat.com>2009-04-06 15:29:07 -0400
committerStephen Gallagher <sgallagh@redhat.com>2009-04-06 15:59:21 -0400
commit29f9384e70029ebe72ad6199eb8f04c0c92a8981 (patch)
treecc42e45043fa2eb6b1b772525234b4b88da9e4a8 /common/configure.ac
parent12454b937b53358e1dbb29dc7649e3f88b9bfd2d (diff)
downloadsssd-29f9384e70029ebe72ad6199eb8f04c0c92a8981.tar.gz
sssd-29f9384e70029ebe72ad6199eb8f04c0c92a8981.tar.xz
sssd-29f9384e70029ebe72ad6199eb8f04c0c92a8981.zip
Fix build system for Collection and INI parser.
Adds ini subdirectory so it will be built, adds some clarification to the README, makes the configure --help more clear about the trace level and enables -Wall reporting.
Diffstat (limited to 'common/configure.ac')
-rw-r--r--common/configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/common/configure.ac b/common/configure.ac
index 83a2c1845..941125d07 100644
--- a/common/configure.ac
+++ b/common/configure.ac
@@ -11,13 +11,13 @@ AC_CONFIG_HEADERS([config.h])
# Enable trace build
AC_ARG_ENABLE([trace],
- [AS_HELP_STRING([--enable-trace],[build with low level tracing enabled])],
+ [AS_HELP_STRING([--enable-trace[=LEVEL]],[build with low level tracing enabled])],
[trace_level="$enableval"],
[trace_level="0"])
AS_IF([test ["$trace_level" -gt "0"] -a ["$trace_level" -lt "8"] ],[AC_SUBST([TRACE_VAR],["-DTRACE_LEVEL=$trace_level"])])
-AC_CONFIG_FILES([Makefile collection/Makefile])
+AC_CONFIG_FILES([Makefile collection/Makefile ini/Makefile])
AC_OUTPUT