summaryrefslogtreecommitdiffstats
path: root/common/collection/configure.ac
diff options
context:
space:
mode:
authorDmitri Pal <dpal@redhat.com>2010-03-05 17:23:00 -0500
committerStephen Gallagher <sgallagh@redhat.com>2010-03-08 13:42:47 -0500
commitdd785dbfa82249c315e102f6a355f1580d3c7436 (patch)
treeda5fd3c62b794431b0c70db1237fcf163ba3da0b /common/collection/configure.ac
parent182a87ca35b3e6c87d7ad6a5e57c0f72efecd743 (diff)
downloadsssd-dd785dbfa82249c315e102f6a355f1580d3c7436.tar.gz
sssd-dd785dbfa82249c315e102f6a355f1580d3c7436.tar.xz
sssd-dd785dbfa82249c315e102f6a355f1580d3c7436.zip
Documentation for collection interface
Passed through the interface and changed the comments to comply with the collection interface.
Diffstat (limited to 'common/collection/configure.ac')
-rw-r--r--common/collection/configure.ac9
1 files changed, 7 insertions, 2 deletions
diff --git a/common/collection/configure.ac b/common/collection/configure.ac
index 2ec6c0194..25aba1628 100644
--- a/common/collection/configure.ac
+++ b/common/collection/configure.ac
@@ -1,4 +1,6 @@
-AC_INIT([collection],[0.4.0],[sssd-devel@lists.fedorahosted.org])
+AC_INIT([collection],
+ [0.4.0],
+ [sssd-devel@lists.fedorahosted.org])
AC_CONFIG_SRCDIR([collection.c])
AC_CONFIG_AUX_DIR([build])
AM_INIT_AUTOMAKE([-Wall -Werror foreign])
@@ -32,6 +34,9 @@ AC_CHECK_FUNC([strcasestr],
AC_DEFINE([COL_MAX_DATA], [65535], [Max length of the data block allowed in the collection value.])
+AC_PATH_PROG([DOXYGEN], [doxygen], [false])
+AM_CONDITIONAL([HAVE_DOXYGEN], [test x$DOXYGEN != xfalse ])
-AC_CONFIG_FILES([Makefile collection.pc])
+
+AC_CONFIG_FILES([Makefile collection.cfg.doxy collection.pc])
AC_OUTPUT