summaryrefslogtreecommitdiffstats
path: root/common/collection/configure.ac
diff options
context:
space:
mode:
authorDmitri Pal <dpal@redhat.com>2009-09-14 12:52:23 -0400
committerStephen Gallagher <sgallagh@redhat.com>2009-10-05 10:32:06 -0400
commita71c65a45586b3f6cd5032016621d41d62a8c4f0 (patch)
tree3cfa4bd303fcb5cdf9c540a7190eebb9768f961b /common/collection/configure.ac
parent4e0314ecad0fb649bcc2d6384a84ae818ef7c972 (diff)
downloadsssd-a71c65a45586b3f6cd5032016621d41d62a8c4f0.tar.gz
sssd-a71c65a45586b3f6cd5032016621d41d62a8c4f0.tar.xz
sssd-a71c65a45586b3f6cd5032016621d41d62a8c4f0.zip
COLLECTION Adding item comparison and sorting
Needed item comparison functions and realized that the easiest way to test them would be using sorting. Since there already been a ticket #73 to do that I added function to sort collection based on different properties of the item. COLLECTION Fixing issues with comparisons COLLECTION Adding do-while to macro
Diffstat (limited to 'common/collection/configure.ac')
-rw-r--r--common/collection/configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/common/collection/configure.ac b/common/collection/configure.ac
index 4858bc61f..cf7a1ff3c 100644
--- a/common/collection/configure.ac
+++ b/common/collection/configure.ac
@@ -24,5 +24,12 @@ AS_IF([test ["$trace_level" -gt "0"] -a ["$trace_level" -lt "8"] ],[AC_SUBST([TR
AC_CHECK_SIZEOF([long])
AC_CHECK_SIZEOF([long long])
+AC_CHECK_FUNC([strcasestr],
+ AC_DEFINE([HAVE_STRCASESTR],
+ [1],
+ [Define if strcasestr exists]),
+ AC_MSG_ERROR("Platform must support strcasestr"))
+
+
AC_CONFIG_FILES([Makefile collection.pc])
AC_OUTPUT