summaryrefslogtreecommitdiffstats
path: root/common/collection/configure.ac
diff options
context:
space:
mode:
authorDmitri Pal <dpal@redhat.com>2009-06-11 10:24:25 -0400
committerStephen Gallagher <sgallagh@redhat.com>2009-07-01 09:17:39 -0400
commit77c350b05bf4a2ec35512699d3450490ba9d6aff (patch)
tree0de356caacdb1e55de01b8f62ed0f859bd924b7d /common/collection/configure.ac
parentf89f2f91cc3ff455041b1ca887904e860de6c896 (diff)
downloadsssd-77c350b05bf4a2ec35512699d3450490ba9d6aff.tar.gz
sssd-77c350b05bf4a2ec35512699d3450490ba9d6aff.tar.xz
sssd-77c350b05bf4a2ec35512699d3450490ba9d6aff.zip
Adding INSERT into collection functionality.
Add was always insterting at the end of the collection. With this change one can control where the item is inserted and deal with the duplicates too. Also one now can extract items from collection using absolute and relative disposition. Using more advanced hashing function.
Diffstat (limited to 'common/collection/configure.ac')
-rw-r--r--common/collection/configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/common/collection/configure.ac b/common/collection/configure.ac
index da34da0a5..504cd4d5c 100644
--- a/common/collection/configure.ac
+++ b/common/collection/configure.ac
@@ -19,5 +19,8 @@ AC_ARG_ENABLE([trace],
[trace_level="0"])
AS_IF([test ["$trace_level" -gt "0"] -a ["$trace_level" -lt "8"] ],[AC_SUBST([TRACE_VAR],["-DTRACE_LEVEL=$trace_level"])])
+AC_CHECK_SIZEOF([long])
+AC_CHECK_SIZEOF([long long])
+
AC_CONFIG_FILES([Makefile collection.pc])
AC_OUTPUT