summaryrefslogtreecommitdiffstats
path: root/common/collection/Makefile.am
diff options
context:
space:
mode:
authorDmitri Pal <dpal@redhat.com>2009-04-06 09:30:01 -0400
committerStephen Gallagher <sgallagh@redhat.com>2009-04-06 15:59:21 -0400
commitde6d6fb21bf367a94c7d292f2c3decd24cf42868 (patch)
tree3eb3a5347eb9b39ede80984a3b2caade1cfa40c4 /common/collection/Makefile.am
parent2ec952c6db27db1d5a21154e2683d1e862643ac8 (diff)
downloadsssd-de6d6fb21bf367a94c7d292f2c3decd24cf42868.tar.gz
sssd-de6d6fb21bf367a94c7d292f2c3decd24cf42868.tar.xz
sssd-de6d6fb21bf367a94c7d292f2c3decd24cf42868.zip
First commit of basic collection API.
Diffstat (limited to 'common/collection/Makefile.am')
-rw-r--r--common/collection/Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/common/collection/Makefile.am b/common/collection/Makefile.am
new file mode 100644
index 000000000..06cf953be
--- /dev/null
+++ b/common/collection/Makefile.am
@@ -0,0 +1,17 @@
+#DEBUG_FLAGS=@DEBUG_VAR@
+TRACE_LEVEL=@TRACE_VAR@
+
+topdir=..
+AM_CPPFLAGS = -I$(topdir) -I$(topdir)/trace $(TRACE_LEVEL)
+
+# Build static libraty
+noinst_LIBRARIES = libcollection.a
+libcollection_a_SOURCES = collection.c collection_tools.c collection.h trace.h collection_tools.h collection_class.h
+
+# Build shared library - reserved for future
+# lib_LTLIBRARIES = libcollection.la
+# libcollection_la_SOURCES = collection.c collection_tools.c collection.h trace.h collection_tools.h collection_class.h
+
+noinst_PROGRAMS = collection_ut
+collection_ut_SOURCES = collection_ut.c
+collection_ut_LDADD = libcollection.a -lm -lz