summaryrefslogtreecommitdiffstats
path: root/common/collection/Makefile.am
diff options
context:
space:
mode:
authorDmitri Pal <dpal@redhat.com>2009-09-14 12:52:23 -0400
committerStephen Gallagher <sgallagh@redhat.com>2009-10-05 10:32:06 -0400
commita71c65a45586b3f6cd5032016621d41d62a8c4f0 (patch)
tree3cfa4bd303fcb5cdf9c540a7190eebb9768f961b /common/collection/Makefile.am
parent4e0314ecad0fb649bcc2d6384a84ae818ef7c972 (diff)
downloadsssd-a71c65a45586b3f6cd5032016621d41d62a8c4f0.tar.gz
sssd-a71c65a45586b3f6cd5032016621d41d62a8c4f0.tar.xz
sssd-a71c65a45586b3f6cd5032016621d41d62a8c4f0.zip
COLLECTION Adding item comparison and sorting
Needed item comparison functions and realized that the easiest way to test them would be using sorting. Since there already been a ticket #73 to do that I added function to sort collection based on different properties of the item. COLLECTION Fixing issues with comparisons COLLECTION Adding do-while to macro
Diffstat (limited to 'common/collection/Makefile.am')
-rw-r--r--common/collection/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/common/collection/Makefile.am b/common/collection/Makefile.am
index 323a5cb0e..8e4e97364 100644
--- a/common/collection/Makefile.am
+++ b/common/collection/Makefile.am
@@ -28,6 +28,7 @@ libcollection_la_SOURCES = \
collection_cnv.c \
collection_queue.c \
collection_stack.c \
+ collection_cmp.c \
collection.h \
collection_tools.h \
collection_priv.h \