summaryrefslogtreecommitdiffstats
path: root/common/collection/Makefile.am
diff options
context:
space:
mode:
authorDmitri Pal <dpal@redhat.com>2009-07-01 18:22:19 -0400
committerStephen Gallagher <sgallagh@redhat.com>2009-07-02 08:16:35 -0400
commit9a28c36d323c14e31a3895ffe7dc905b815291f8 (patch)
tree9f43b63b340092f9e63d7e403a36a22f51643124 /common/collection/Makefile.am
parent203d8d4ffb03897ab995bc2a6311f2a603245269 (diff)
downloadsssd-9a28c36d323c14e31a3895ffe7dc905b815291f8.tar.gz
sssd-9a28c36d323c14e31a3895ffe7dc905b815291f8.tar.xz
sssd-9a28c36d323c14e31a3895ffe7dc905b815291f8.zip
Queue and stack APIs using collection.
Patch adds two interfaces for stack and queue using collection as underlaying implementation. It also fixes a bug in the insterion code - the unsigned properties were created as long.
Diffstat (limited to 'common/collection/Makefile.am')
-rw-r--r--common/collection/Makefile.am10
1 files changed, 9 insertions, 1 deletions
diff --git a/common/collection/Makefile.am b/common/collection/Makefile.am
index 8df9fc6b7..fe0749045 100644
--- a/common/collection/Makefile.am
+++ b/common/collection/Makefile.am
@@ -15,12 +15,20 @@ libcollection_la_SOURCES = \
collection.c \
collection_tools.c \
collection_cnv.c \
+ collection_queue.c \
+ collection_stack.c \
collection.h \
collection_tools.h \
collection_priv.h \
+ collection_queue.h \
+ collection_stack.h \
../trace/trace.h
# Build unit test
-noinst_PROGRAMS = collection_ut
+noinst_PROGRAMS = collection_ut collection_stack_ut collection_queue_ut
collection_ut_SOURCES = collection_ut.c
collection_ut_LDADD = libcollection.la
+collection_stack_ut_SOURCES = collection_stack_ut.c
+collection_stack_ut_LDADD = libcollection.la
+collection_queue_ut_SOURCES = collection_queue_ut.c
+collection_queue_ut_LDADD = libcollection.la