summaryrefslogtreecommitdiffstats
path: root/common/collection/Makefile.am
diff options
context:
space:
mode:
authorStephen Gallagher <sgallagh@redhat.com>2009-05-12 11:51:20 -0400
committerSimo Sorce <ssorce@redhat.com>2009-05-14 11:34:04 -0400
commit798af224b66e25b694569f70e86262f7867917cf (patch)
tree80950d451cc75c99ad3cd8c5e07faa91ec34b1bc /common/collection/Makefile.am
parent24ad71529edd3ef6cfe7785d6c6e4f51d5cc42db (diff)
downloadsssd-798af224b66e25b694569f70e86262f7867917cf.tar.gz
sssd-798af224b66e25b694569f70e86262f7867917cf.tar.xz
sssd-798af224b66e25b694569f70e86262f7867917cf.zip
Enable modular build of common SSSD libraries
Allow configuration and build of individual SSSD utility libraries from their own subdirectories. Building all utilities is still possible recursively from the common root.
Diffstat (limited to 'common/collection/Makefile.am')
-rw-r--r--common/collection/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/common/collection/Makefile.am b/common/collection/Makefile.am
index c47327d45..1d8f93738 100644
--- a/common/collection/Makefile.am
+++ b/common/collection/Makefile.am
@@ -3,12 +3,13 @@ TRACE_LEVEL=@TRACE_VAR@
topdir=..
AM_CPPFLAGS = -Wall -I$(topdir) -I$(topdir)/trace $(TRACE_LEVEL)
+ACLOCAL_AMFLAGS = -I m4
# Set up the pkg-config file
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = collection.pc
-# Build libraty
+# Build library
lib_LTLIBRARIES = libcollection.la
libcollection_la_SOURCES = collection.c collection_tools.c collection_tools.h collection_class.h
include_HEADERS = collection.h collection_tools.h