summaryrefslogtreecommitdiffstats
path: root/common/Makefile.am
diff options
context:
space:
mode:
authorJohn Dennis <jdennis@jdennis.(none)>2009-07-14 11:25:37 -0400
committerStephen Gallagher <sgallagh@redhat.com>2009-07-15 08:56:51 -0400
commitdf8b16d7d55d97001ed71f629fc21511ec9f8d3b (patch)
tree601fc66ee7526f2035306e256265b5d9a0fab038 /common/Makefile.am
parent7f5e857a11f932c247b5a96d0d86768226ba2e96 (diff)
downloadsssd-df8b16d7d55d97001ed71f629fc21511ec9f8d3b.tar.gz
sssd-df8b16d7d55d97001ed71f629fc21511ec9f8d3b.tar.xz
sssd-df8b16d7d55d97001ed71f629fc21511ec9f8d3b.zip
add path_utils filesystem path manipulation utility functions
remove trace macro, not needed modifications to satisfy Stephen's checkin review correct spelling of PATH_UTILS_ERROR_NOT_FULLY_NORMALIZED add checks for truncation, return error add checks for getcwd errors modify (dst >= dst_end) test to be (dst > dst_end) remove all use of tabs remove all trailing whitespace add missing truncation check after strncpy() Fix path_utils.pc Also correct a minor typo.
Diffstat (limited to 'common/Makefile.am')
-rw-r--r--common/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/common/Makefile.am b/common/Makefile.am
index 42bd483a1..d3329c9b1 100644
--- a/common/Makefile.am
+++ b/common/Makefile.am
@@ -1,5 +1,5 @@
ACLOCAL_AMFLAGS = -I m4
-SUBDIRS = trace collection ini dhash
+SUBDIRS = trace collection ini dhash path_utils
if SINGLELIB
# Build all components as a single shared library
lib_LTLIBRARIES = libsssd_util.la