summaryrefslogtreecommitdiffstats
path: root/common/Makefile.am
diff options
context:
space:
mode:
authorJohn Dennis <jdennis@redhat.com>2009-04-16 17:48:13 -0400
committerSimo Sorce <ssorce@redhat.com>2009-04-22 04:42:43 -0400
commitb2a771f96f6344841a78015a591418e5ab6ef608 (patch)
tree923f1cb92dcd6caa9acd0d2c83820c1aa85333ba /common/Makefile.am
parentbfbaa2bd29524b295b6cedca553cd2bec69db865 (diff)
downloadsssd-b2a771f96f6344841a78015a591418e5ab6ef608.tar.gz
sssd-b2a771f96f6344841a78015a591418e5ab6ef608.tar.xz
sssd-b2a771f96f6344841a78015a591418e5ab6ef608.zip
add dynamic hash table data structure implementation
Apply suggested fixes by Simo after code review * return statements no longer use () unless it's an expression * remove all use of assert() in library * use bool,true,false instead of int,TRUE,FALSE * add check for NULL hash table in public entry points * example code in header file now a seperate file * assure consistent use of unsigned long data type * add more debugging support * break out generation of integer key into convert_key() function * table parameters now tunable rather than hardcoded * table can now accept custom alloc()/free() functions * add function create_table_ex() to pass extra table parameters * remove MUL(), DIV(), MOD() macros * hash statistics now separate struct which can be queried * test program now accepts tuning parameters, iteration count; has better error checking and reporting fix min/max load factor comman line args in test program
Diffstat (limited to 'common/Makefile.am')
-rw-r--r--common/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/common/Makefile.am b/common/Makefile.am
index ea23cb953..94ccd27b4 100644
--- a/common/Makefile.am
+++ b/common/Makefile.am
@@ -1 +1 @@
-SUBDIRS = collection ini trace
+SUBDIRS = collection ini trace dhash