summaryrefslogtreecommitdiffstats
path: root/common/Makefile.am
diff options
context:
space:
mode:
authorDmitri Pal <dpal@redhat.com>2009-07-13 19:35:31 -0400
committerStephen Gallagher <sgallagh@redhat.com>2009-07-15 11:19:46 -0400
commit735ac5cb6596ac7219881a8be1b215825de9401b (patch)
tree5a3b83f81260e93ad9f863b94843c9409dbc7aa3 /common/Makefile.am
parent9689454cb2d3d3b3c9e02a32ab9db13f49e8d5a2 (diff)
downloadsssd-735ac5cb6596ac7219881a8be1b215825de9401b.tar.gz
sssd-735ac5cb6596ac7219881a8be1b215825de9401b.tar.xz
sssd-735ac5cb6596ac7219881a8be1b215825de9401b.zip
ELAPI First part of the interface
This is just a part of the interface, a beginning. Most likely some of the functions will be altered but it is a starting point. For example in future there will be a way to override some of the parts of the default template using the application configuration file. Removed obfuscation of the data types based on discussion with Simo.
Diffstat (limited to 'common/Makefile.am')
-rw-r--r--common/Makefile.am7
1 files changed, 4 insertions, 3 deletions
diff --git a/common/Makefile.am b/common/Makefile.am
index d3329c9b1..445a84356 100644
--- a/common/Makefile.am
+++ b/common/Makefile.am
@@ -1,5 +1,5 @@
ACLOCAL_AMFLAGS = -I m4
-SUBDIRS = trace collection ini dhash path_utils
+SUBDIRS = trace collection ini dhash path_utils elapi
if SINGLELIB
# Build all components as a single shared library
lib_LTLIBRARIES = libsssd_util.la
@@ -7,11 +7,12 @@ libsssd_util_la_SOURCES =
libsssd_util_la_LIBADD = \
collection/libcollection.la \
ini/libini_config.la \
- dhash/libdhash.la
+ dhash/libdhash.la \
+ elapi/libelapi.la
libsssd_util_la_CFLAGS = $(AM_CFLAGS) \
-I ./collection \
-I ./ini \
-I ./dhash \
+ -I ./elapi \
-I ./trace
endif
-