summaryrefslogtreecommitdiffstats
path: root/common/Makefile.am
diff options
context:
space:
mode:
authorStephen Gallagher <sgallagh@redhat.com>2009-05-12 11:56:27 -0400
committerSimo Sorce <ssorce@redhat.com>2009-05-14 11:34:04 -0400
commit50c10e1f61a1bef93a7f768ad6edb28989f1761b (patch)
treea0d44730681e5fccaeafa5cc9b8d8fb150182b96 /common/Makefile.am
parent798af224b66e25b694569f70e86262f7867917cf (diff)
downloadsssd-50c10e1f61a1bef93a7f768ad6edb28989f1761b.tar.gz
sssd-50c10e1f61a1bef93a7f768ad6edb28989f1761b.tar.xz
sssd-50c10e1f61a1bef93a7f768ad6edb28989f1761b.zip
Enable building a single libsssd_utils.so from common
Diffstat (limited to 'common/Makefile.am')
-rw-r--r--common/Makefile.am19
1 files changed, 18 insertions, 1 deletions
diff --git a/common/Makefile.am b/common/Makefile.am
index 276bbb2a1..47d7c4a99 100644
--- a/common/Makefile.am
+++ b/common/Makefile.am
@@ -1,2 +1,19 @@
-SUBDIRS = collection ini trace dhash
ACLOCAL_AMFLAGS = -I m4
+
+if SINGLELIB
+# Build all components as a single shared library
+lib_LTLIBRARIES = libsssd_util.la
+libsssd_util_la_SOURCES = \
+ collection/collection.c \
+ collection/collection_tools.c \
+ ini/ini_config.c \
+ dhash/dhash.c
+libsssd_util_la_CFLAGS = $(AM_CFLAGS) \
+ -I ./collection \
+ -I ./ini \
+ -I ./dhash \
+ -I ./trace
+else
+SUBDIRS = collection ini trace dhash
+endif
+