summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJakub Hrozek <jhrozek@redhat.com>2015-12-17 07:32:04 +0100
committerJakub Hrozek <jhrozek@redhat.com>2016-01-13 11:28:45 +0100
commited7a26276ad68d55bf10058dda0d617dc7666edf (patch)
treea595444dc84f5e91fe508bd9e90c04795b339538 /Makefile.am
parent23674dfef4225b90d45c27b88fe72dc37b22e32d (diff)
downloadsssd-ed7a26276ad68d55bf10058dda0d617dc7666edf.tar.gz
sssd-ed7a26276ad68d55bf10058dda0d617dc7666edf.tar.xz
sssd-ed7a26276ad68d55bf10058dda0d617dc7666edf.zip
foo
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am37
1 files changed, 22 insertions, 15 deletions
diff --git a/Makefile.am b/Makefile.am
index a9d3f25d3..6378b7482 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -178,7 +178,6 @@ if HAVE_CHECK
auth-tests \
ipa_ldap_opt-tests \
ad_ldap_opt-tests \
- simple_access-tests \
crypto-tests \
util-tests \
debug-tests \
@@ -245,6 +244,7 @@ if HAVE_CMOCKA
test_cert_utils \
test_ldap_id_cleanup \
test_data_provider_be \
+ simple-access-tests \
$(NULL)
if HAVE_LIBRESOLV
@@ -1683,20 +1683,6 @@ ad_ldap_opt_tests_LDADD = \
$(TALLOC_LIBS) \
libsss_test_common.la
-simple_access_tests_SOURCES = \
- src/tests/simple_access-tests.c \
- src/providers/simple/simple_access.c \
- src/providers/simple/simple_access_check.c \
- $(NULL)
-simple_access_tests_LDADD = \
- $(LIBADD_DL) \
- $(CHECK_LIBS) \
- $(SSSD_LIBS) \
- $(SSSD_INTERNAL_LTLIBS) \
- libsss_test_common.la \
- libdlopen_test_providers.la \
- $(NULL)
-
util_tests_SOURCES = \
src/tests/util-tests.c \
$(NULL)
@@ -2626,6 +2612,27 @@ test_data_provider_be_LDADD = \
libdlopen_test_providers.la \
$(NULL)
+EXTRA_simple_access_tests_DEPENDENCIES = \
+ $(ldblib_LTLIBRARIES)
+simple_access_tests_SOURCES = \
+ src/tests/cmocka/test_simple_access.c \
+ src/tests/cmocka/common_mock_be.c \
+ src/providers/simple/simple_access.c \
+ src/providers/simple/simple_access_check.c \
+ $(NULL)
+simple_access_tests_CFLAGS = \
+ $(AM_CFLAGS) \
+ $(NULL)
+simple_access_tests_LDFLAGS = \
+ $(NULL)
+simple_access_tests_LDADD = \
+ $(CMOCKA_LIBS) \
+ $(SSSD_LIBS) \
+ $(SSSD_INTERNAL_LTLIBS) \
+ libsss_test_common.la \
+ libdlopen_test_providers.la \
+ $(NULL)
+
endif # HAVE_CMOCKA
noinst_PROGRAMS = pam_test_client