summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorSumit Bose <sbose@redhat.com>2015-11-05 18:20:27 +0100
committerJakub Hrozek <jhrozek@redhat.com>2015-11-26 16:39:49 +0100
commit544a20de7667f05c1a406c4dea0706b0ab507430 (patch)
treedca48b12957626f2ebae2fb2b0f9a96ef617713e /Makefile.am
parentd0de7701d44c7a75210a9cb04634913ce3a94bfb (diff)
downloadsssd-544a20de7667f05c1a406c4dea0706b0ab507430.tar.gz
sssd-544a20de7667f05c1a406c4dea0706b0ab507430.tar.xz
sssd-544a20de7667f05c1a406c4dea0706b0ab507430.zip
p11: enable ocsp checks
This patch enables the Online Certificate Status Protocol in NSS and adds an option to disable it if needed. To make further tuning of certificate verification more easy it is not an option on its own but an option to the new certificate_verification configuration option. Resolves https://fedorahosted.org/sssd/ticket/2812 Reviewed-by: Jakub Hrozek <jhrozek@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index ba59b16b4..848f70e48 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -3163,6 +3163,7 @@ proxy_child_LDADD = \
p11_child_SOURCES = \
src/p11_child/p11_child_nss.c \
src/util/atomic_io.c \
+ src/util/util.c \
$(NULL)
p11_child_CFLAGS = \
$(AM_CFLAGS) \
@@ -3172,6 +3173,7 @@ p11_child_CFLAGS = \
p11_child_LDADD = \
libsss_debug.la \
$(TALLOC_LIBS) \
+ $(DHASH_LIBS) \
$(POPT_LIBS) \
$(NSS_LIBS) \
libsss_crypt.la \