summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorLukas Slebodnik <lukas.slebodnik@intrak.sk>2013-08-30 23:13:26 +0200
committerJakub Hrozek <jhrozek@redhat.com>2013-09-09 17:20:52 +0200
commit9c393e2c39e8d3a00a1ba399a80c4c3291857242 (patch)
tree223786ebd790f3c974fb6753f7014772cc17ba89 /Makefile.am
parente64a66e620aad51c1fada6138362c5a186af178a (diff)
downloadsssd-9c393e2c39e8d3a00a1ba399a80c4c3291857242.tar.gz
sssd-9c393e2c39e8d3a00a1ba399a80c4c3291857242.tar.xz
sssd-9c393e2c39e8d3a00a1ba399a80c4c3291857242.zip
AUTOTOOLS: More robust detection of inotify.
We checked only header file "sys/inotify" for detection whether inotify works. Some platforms do not have built in inotify, but contain library, which provides inotify-compatible interface. This patch adds more robust detection of inotify in configuration time and appends linker flags to Makefile if inotify is provided by library.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 2e1073047..cb4bea7a7 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -568,6 +568,7 @@ sssd_SOURCES = \
src/confdb/confdb_setup.c
sssd_LDADD = \
$(SSSD_LIBS) \
+ $(INOTIFY_LIBS) \
$(LIBNL_LIBS) \
$(KEYUTILS_LIBS) \
libsss_util.la