summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJakub Hrozek <jhrozek@redhat.com>2013-02-23 10:44:54 +0100
committerJakub Hrozek <jhrozek@redhat.com>2013-03-19 22:14:02 +0100
commit8b8019fe3dd1564fba657e219ec20ff816c7ffdb (patch)
tree2aa937b4e0bd8f97cb21ce25a5b19272041b8fbd /Makefile.am
parent26590d31f492dbbd36be6d0bde46a4bd3b221edb (diff)
downloadsssd-8b8019fe3dd1564fba657e219ec20ff816c7ffdb.tar.gz
sssd-8b8019fe3dd1564fba657e219ec20ff816c7ffdb.tar.xz
sssd-8b8019fe3dd1564fba657e219ec20ff816c7ffdb.zip
Resolve GIDs in the simple access provider
Changes the simple access provider's interface to be asynchronous. When the simple access provider encounters a group that has gid, but no meaningful name, it attempts to resolve the name using the be_file_account_request function. Some providers (like the AD provider) might perform initgroups without resolving the group names. In order for the simple access provider to work correctly, we need to resolve the groups before performing the access check. In AD provider, the situation is even more tricky b/c the groups HAVE name, but their name attribute is set to SID and they are set as non-POSIX
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am17
1 files changed, 13 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index dc0465a8c..eea535e81 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1008,14 +1008,22 @@ ad_ldap_opt_tests_LDADD = \
simple_access_tests_SOURCES = \
src/tests/simple_access-tests.c \
src/tests/common.c \
- src/providers/simple/simple_access.c
+ src/providers/simple/simple_access_check.c \
+ src/providers/data_provider_be.c \
+ src/providers/data_provider_fo.c \
+ src/providers/data_provider_callbacks.c \
+ $(SSSD_FAILOVER_OBJ)
simple_access_tests_CFLAGS = \
$(AM_CFLAGS) \
- $(CHECK_CFLAGS)
+ $(CHECK_CFLAGS) \
+ -DUNIT_TESTING
simple_access_tests_LDADD = \
$(SSSD_LIBS) \
+ $(CARES_LIBS) \
$(CHECK_LIBS) \
- libsss_util.la
+ $(PAM_LIBS) \
+ libsss_util.la \
+ libsss_test_common.la
util_tests_SOURCES = \
src/tests/util-tests.c
@@ -1347,7 +1355,8 @@ libsss_proxy_la_LDFLAGS = \
-module
libsss_simple_la_SOURCES = \
- src/providers/simple/simple_access.c
+ src/providers/simple/simple_access.c \
+ src/providers/simple/simple_access_check.c
libsss_simple_la_CFLAGS = \
$(AM_CFLAGS)
libsss_simple_la_LIBADD = \