summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorStephen Gallagher <sgallagh@redhat.com>2011-05-18 10:23:08 -0400
committerStephen Gallagher <sgallagh@redhat.com>2011-05-23 10:57:44 -0400
commite92ecf948387d1687a5e772ac86e606b1b6af957 (patch)
tree6124fa86e785d6fe42700aa08b90379169926d26 /Makefile.am
parent2ea20b30f0e4ea9dd779f06dd7e0de6973913195 (diff)
downloadsssd-e92ecf948387d1687a5e772ac86e606b1b6af957.tar.gz
sssd-e92ecf948387d1687a5e772ac86e606b1b6af957.tar.xz
sssd-e92ecf948387d1687a5e772ac86e606b1b6af957.zip
Build SSSD plugins without a version number
The version is both fake and unused, so we'll stop creating the versioned file and use only the unversioned .so. This is safe to do for now because all of the plugins are built at the same time as the interface.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 5 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index 767e67597..3d9393b48 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -788,7 +788,7 @@ libsss_ldap_la_LIBADD = \
$(KRB5_LIBS) \
libsss_crypt.la
libsss_ldap_la_LDFLAGS = \
- -version-info 1:0:0 \
+ -avoid-version \
-module
libsss_proxy_la_SOURCES = \
@@ -802,7 +802,7 @@ libsss_proxy_la_CFLAGS = \
libsss_proxy_la_LIBADD = \
$(PAM_LIBS)
libsss_proxy_la_LDFLAGS = \
- -version-info 1:0:0 \
+ -avoid-version \
-module
libsss_simple_la_SOURCES = \
@@ -812,7 +812,7 @@ libsss_simple_la_CFLAGS = \
libsss_simple_la_LIBADD = \
$(PAM_LIBS)
libsss_simple_la_LDFLAGS = \
- -version-info 1:0:0 \
+ -avoid-version \
-module
libsss_krb5_la_SOURCES = \
@@ -837,7 +837,7 @@ libsss_krb5_la_LIBADD = \
$(KEYUTILS_LIBS) \
$(KRB5_LIBS)
libsss_krb5_la_LDFLAGS = \
- -version-info 1:0:0 \
+ -avoid-version \
-module
libsss_ipa_la_SOURCES = \
@@ -887,7 +887,7 @@ libsss_ipa_la_LIBADD = \
$(KRB5_LIBS) \
libsss_crypt.la
libsss_ipa_la_LDFLAGS = \
- -version-info 1:0:0 \
+ -avoid-version \
-module
krb5_child_SOURCES = \