summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorStephen Gallagher <sgallagh@redhat.com>2012-04-22 13:52:51 -0400
committerStephen Gallagher <sgallagh@redhat.com>2012-05-03 14:09:13 -0400
commit505e75ba28b42bb3de7a6d55de825091b70cc2b2 (patch)
tree30ea6812c9142ba218bb0b5efdb6c30d9226df16 /Makefile.am
parent817b1bcafff27cc67630dd0cbd36df708c05fccc (diff)
downloadsssd-505e75ba28b42bb3de7a6d55de825091b70cc2b2.tar.gz
sssd-505e75ba28b42bb3de7a6d55de825091b70cc2b2.tar.xz
sssd-505e75ba28b42bb3de7a6d55de825091b70cc2b2.zip
LDAP: Add helper routines for ID-mapping
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index d31515e9b..348ad2787 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1096,6 +1096,8 @@ libsss_ldap_common_la_SOURCES = \
src/providers/ldap/sdap_child_helpers.c \
src/providers/ldap/sdap_fd_events.c \
src/providers/ldap/sdap_id_op.c \
+ src/providers/ldap/sdap_idmap.c \
+ src/providers/ldap/sdap_idmap.h \
src/providers/ldap/sdap.c
if BUILD_SUDO
@@ -1140,7 +1142,8 @@ libsss_ldap_la_LIBADD = \
$(DHASH_LIBS) \
$(KRB5_LIBS) \
libsss_util.la \
- libsss_ldap_common.la
+ libsss_ldap_common.la \
+ libsss_idmap.la
libsss_ldap_la_LDFLAGS = \
-avoid-version \
-module
@@ -1231,7 +1234,8 @@ libsss_ipa_la_LIBADD = \
libsss_util.la \
libsss_ldap_common.la \
libsss_krb5_common.la \
- libipa_hbac.la
+ libipa_hbac.la \
+ libsss_idmap.la
libsss_ipa_la_LDFLAGS = \
-avoid-version \
-module