summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorStephen Gallagher <sgallagh@redhat.com>2011-05-18 16:38:38 -0400
committerStephen Gallagher <sgallagh@redhat.com>2011-07-08 15:12:24 -0400
commit4dd615c01357b8715711aad6820ba9595d3ad377 (patch)
treea56cee70c8a4f4f7e920801e718cbc88eae9e957 /Makefile.am
parent31442edcf62c284d5d983bda48e51ae55b70ebdf (diff)
downloadsssd-4dd615c01357b8715711aad6820ba9595d3ad377.tar.gz
sssd-4dd615c01357b8715711aad6820ba9595d3ad377.tar.xz
sssd-4dd615c01357b8715711aad6820ba9595d3ad377.zip
Add HBAC evaluator and tests
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am28
1 files changed, 27 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index b8423bab3..ee7c4685d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -33,6 +33,7 @@ initdir = @initdir@
systemdunitdir = @systemdunitdir@
logpath = @logpath@
pubconfpath = @pubconfpath@
+pkgconfigdir = $(libdir)/pkgconfig
AM_CFLAGS =
if WANT_AUX_INFO
@@ -44,6 +45,8 @@ if HAVE_GCC
-Werror-implicit-function-declaration
endif
+dist_pkgconfig_DATA =
+
ACLOCAL_AMFLAGS = -I m4 -I .
sbin_PROGRAMS = \
@@ -80,7 +83,8 @@ if HAVE_CHECK
ipa_ldap_opt-tests \
simple_access-tests \
crypto-tests \
- util-tests
+ util-tests \
+ ipa_hbac-tests
endif
check_PROGRAMS = \
@@ -365,6 +369,16 @@ libsss_util_la_LIBADD = \
libsss_crypt.la \
libsss_debug.la
+lib_LTLIBRARIES = libipa_hbac.la
+dist_pkgconfig_DATA += src/providers/ipa/ipa_hbac.pc
+libipa_hbac_la_SOURCES = \
+ src/providers/ipa/hbac_evaluator.c
+libipa_hbac_la_LDFLAGS = \
+ -version 0:0:0
+
+include_HEADERS = \
+ src/providers/ipa/ipa_hbac.h
+
####################
# Program Binaries #
####################
@@ -711,6 +725,18 @@ crypto_tests_LDADD = \
$(CHECK_LIBS) \
libsss_test_common.la
+ipa_hbac_tests_SOURCES = \
+ src/tests/ipa_hbac-tests.c
+ipa_hbac_tests_CFLAGS = \
+ $(AM_CFLAGS) \
+ $(CHECK_CFLAGS)
+ipa_hbac_tests_LDADD = \
+ $(SSSD_LIBS) \
+ $(CHECK_LIBS) \
+ libsss_util.la \
+ libsss_test_common.la \
+ libipa_hbac.la
+
endif
stress_tests_SOURCES = \