summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJakub Hrozek <jhrozek@redhat.com>2011-04-05 15:42:13 +0200
committerStephen Gallagher <sgallagh@redhat.com>2011-04-12 09:26:26 -0400
commit2a5790216f57e9bdfb2930d52860bb5300366536 (patch)
tree41d9ad9913dcc3cda3aed38f64f5f1c6ef251d18 /Makefile.am
parent00e9f24707a2d221ed2be40289669e4fd731713e (diff)
downloadsssd-2a5790216f57e9bdfb2930d52860bb5300366536.tar.gz
sssd-2a5790216f57e9bdfb2930d52860bb5300366536.tar.xz
sssd-2a5790216f57e9bdfb2930d52860bb5300366536.zip
Provide a configuration option to use systemd unit file
https://fedorahosted.org/sssd/ticket/837
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am15
1 files changed, 12 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index b445f9c81..d8eb28d3e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -30,6 +30,7 @@ pluginpath = @pluginpath@
pidpath = @pidpath@
pipepath = @pipepath@
initdir = @initdir@
+systemdunitdir = @systemdunitdir@
logpath = @logpath@
pubconfpath = @pubconfpath@
@@ -974,6 +975,11 @@ update-po:
#######################
dist_init_SCRIPTS =
+dist_systemdunit_DATA =
+if HAVE_SYSTEMD_UNIT
+ dist_systemdunit_DATA += \
+ src/sysv/systemd/sssd.service
+else
if HAVE_SUSE
dist_init_SCRIPTS += \
src/sysv/SUSE/sssd
@@ -986,6 +992,7 @@ else
src/sysv/sssd
endif
endif
+endif
dist_sssdconf_DATA = \
@@ -1003,18 +1010,15 @@ installsssddirs::
$(DESTDIR)$(includedir) \
$(DESTDIR)$(libdir) \
$(DESTDIR)$(sbindir) \
- $(DESTDIR)$(initdir) \
$(DESTDIR)$(mandir) \
$(DESTDIR)$(pluginpath) \
$(DESTDIR)$(libdir)/ldb \
- $(DESTDIR)$(infpintrospectdir) \
$(DESTDIR)$(dbusintrospectdir) \
$(DESTDIR)$(pipepath)/private \
$(DESTDIR)$(sssdlibdir) \
$(DESTDIR)$(sssdconfdir) \
$(DESTDIR)$(dbpath) \
$(DESTDIR)$(pidpath) \
- $(DESTDIR)$(initdir) \
$(DESTDIR)$(logpath) \
$(DESTDIR)$(pubconfpath)
@@ -1041,6 +1045,11 @@ if BUILD_PYTHON_BINDINGS
fi
endif
mkdir -p doc $(DESTDIR)/$(docdir); cp -a doc $(DESTDIR)/$(docdir)/
+if HAVE_SYSTEMD_UNIT
+ mkdir -p $(DESTDIR)$(systemdunitdir)
+else
+ mkdir -p $(DESTDIR)$(initdir)
+endif
install-data-hook:
rm $(DESTDIR)/$(nsslibdir)/libnss_sss.so.2 \