summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJakub Hrozek <jhrozek@redhat.com>2012-04-09 23:30:58 +0200
committerStephen Gallagher <sgallagh@redhat.com>2012-04-20 10:55:14 -0400
commit9959c512ac3ba36f7a0db7614f0357ce0bae748f (patch)
tree43d9baf2288bb7ea9eee6af7910b7f60c17fc54f /Makefile.am
parente3c99ae355408933b03357220f3db09423bd40dd (diff)
downloadsssd-9959c512ac3ba36f7a0db7614f0357ce0bae748f.tar.gz
sssd-9959c512ac3ba36f7a0db7614f0357ce0bae748f.tar.xz
sssd-9959c512ac3ba36f7a0db7614f0357ce0bae748f.zip
Move atomic io function to a separate module
We'll be using it on various places of the SSSD. The function is in its own file to allow using just the one piece without having to drag in the whole util.c module.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index c62ea8c1c..919fb9b25 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -332,6 +332,7 @@ dist_noinst_HEADERS = \
src/util/user_info_msg.h \
src/util/murmurhash3.h \
src/util/mmap_cache.h \
+ src/util/atomic_io.h \
src/monitor/monitor.h \
src/monitor/monitor_interfaces.h \
src/responder/common/responder.h \
@@ -449,6 +450,7 @@ libsss_util_la_SOURCES = \
src/util/sss_utf8.c \
src/util/sss_tc_utf8.c \
src/util/murmurhash3.c \
+ src/util/atomic_io.c \
src/util/sss_selinux.c
libsss_util_la_LIBADD = \
$(SSSD_LIBS) \