summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJan Zeleny <jzeleny@redhat.com>2012-06-11 06:00:22 -0400
committerStephen Gallagher <sgallagh@redhat.com>2012-06-21 15:30:21 -0400
commit33f8decd07d4364a7bfbb051e8dc2da2424b0d01 (patch)
tree4b0cd29d99e681d43814eda8f7c2b4679a0a0a1c /Makefile.am
parent58aa9256ef825562daf7588ee286b818113a8f2f (diff)
downloadsssd-33f8decd07d4364a7bfbb051e8dc2da2424b0d01.tar.gz
sssd-33f8decd07d4364a7bfbb051e8dc2da2424b0d01.tar.xz
sssd-33f8decd07d4364a7bfbb051e8dc2da2424b0d01.zip
PAC responder: test suite
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am19
1 files changed, 18 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 63adbae53..fd989c49a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -119,7 +119,8 @@ if HAVE_CHECK
util-tests \
debug-tests \
ipa_hbac-tests \
- sss_idmap-tests
+ sss_idmap-tests \
+ pac_responder-tests
endif
check_PROGRAMS = \
@@ -987,6 +988,22 @@ sss_idmap_tests_LDADD = \
libsss_test_common.la \
libsss_idmap.la
+pac_responder_tests_SOURCES = \
+ src/tests/pac_responder-tests.c \
+ src/responder/pac/pacsrv_utils.c
+pac_responder_tests_CFLAGS = \
+ $(AM_CFLAGS) \
+ $(NDR_KRB5PAC_CFLAGS) \
+ $(CHECK_CFLAGS)
+pac_responder_tests_LDADD = \
+ $(CHECK_LIBS) \
+ $(TALLOC_LIBS) \
+ $(NDR_KRB5PAC_LIBS) \
+ $(SSSD_LIBS) \
+ libsss_idmap.la \
+ libsss_debug.la \
+ libsss_util.la \
+ libsss_test_common.la
endif
stress_tests_SOURCES = \