summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorStephen Gallagher <sgallagh@redhat.com>2011-12-20 10:47:41 -0500
committerStephen Gallagher <sgallagh@redhat.com>2011-12-20 13:37:28 -0500
commitd844aab866ae237844360cea70e2dccdc90c783d (patch)
treef65426bb18fee843d5497d28497dc248593c6953 /Makefile.am
parentf1055c2a8036bb11b5788f969078edee8ba5326e (diff)
downloadsssd-d844aab866ae237844360cea70e2dccdc90c783d.tar.gz
sssd-d844aab866ae237844360cea70e2dccdc90c783d.tar.xz
sssd-d844aab866ae237844360cea70e2dccdc90c783d.zip
PAM: make initgroups timeout work across multiple clients
Instead of timing out the initgroups lookup on a per-cctx basis, we will maintain a hash table of recently-seen users and use this instead. This will allow SSSD to handle user's logging into multiple services simultaneously more graciously, as well as playing nicer with SSH (which makes calls to PAM both before and after a fork). https://fedorahosted.org/sssd/ticket/1063
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index f6b340a57..4c330a4ed 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -309,6 +309,7 @@ dist_noinst_HEADERS = \
src/responder/common/responder.h \
src/responder/common/responder_packet.h \
src/responder/pam/pamsrv.h \
+ src/responder/pam/pam_helpers.h \
src/responder/nss/nsssrv.h \
src/responder/nss/nsssrv_private.h \
src/responder/nss/nsssrv_netgroup.h \
@@ -445,6 +446,7 @@ sssd_pam_SOURCES = \
src/responder/pam/pamsrv.c \
src/responder/pam/pamsrv_cmd.c \
src/responder/pam/pamsrv_dp.c \
+ src/responder/pam/pam_helpers.c \
$(SSSD_RESPONDER_OBJ)
sssd_pam_LDADD = \
$(TDB_LIBS) \