summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJan Cholasta <jcholast@redhat.com>2012-02-27 08:04:26 -0500
committerStephen Gallagher <sgallagh@redhat.com>2012-02-27 11:52:34 -0500
commita836d70ad64013ec1d407388a9416ecb3d1cc992 (patch)
tree9ae01187f39f95376d21cfe4709c19a3b3cb7db9 /Makefile.am
parent26202f8e447b694843d3fb9532673dc280a4c245 (diff)
downloadsssd-a836d70ad64013ec1d407388a9416ecb3d1cc992.tar.gz
sssd-a836d70ad64013ec1d407388a9416ecb3d1cc992.tar.xz
sssd-a836d70ad64013ec1d407388a9416ecb3d1cc992.zip
SSH: Replace blocking getaddrinfo call in the responder with asynchronous resolver code
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index a1fafcd35..815816585 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -533,9 +533,11 @@ if BUILD_SSH
sssd_ssh_SOURCES = \
src/responder/ssh/sshsrv.c \
src/responder/ssh/sshsrv_cmd.c \
- $(SSSD_RESPONDER_OBJ)
+ $(SSSD_RESPONDER_OBJ) \
+ $(SSSD_RESOLV_OBJ)
sssd_ssh_LDADD = \
$(SSSD_LIBS) \
+ $(CARES_LIBS) \
libsss_util.la
endif