summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorStephen Gallagher <sgallagh@redhat.com>2011-10-13 15:56:46 -0400
committerStephen Gallagher <sgallagh@redhat.com>2011-10-14 08:57:56 -0400
commit8b1f525acd20f36c836e827de3c251088961c5d9 (patch)
tree21db1d9e5d9b969641a4a3a2ad72b70a1a2bf37b /Makefile.am
parentc1fcc832ccfc237caac8b99be238cf2d598f908c (diff)
downloadsssd-8b1f525acd20f36c836e827de3c251088961c5d9.tar.gz
sssd-8b1f525acd20f36c836e827de3c251088961c5d9.tar.xz
sssd-8b1f525acd20f36c836e827de3c251088961c5d9.zip
BUILDSYS: Fix --without-manpages
We weren't honoring the --without-manpages option, and this was causing builds to break. Note: 'make dist[check]' will not work if you have configured with --without-manpages because it will not be able to pre-generate the translation files necessary for tarball release.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 78ec82e75..58c792825 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,6 +1,10 @@
DISTCHECK_CONFIGURE_FLAGS = --with-ldb-lib-dir="$$dc_install_base"/lib/ldb
-SUBDIRS = po src/man
+SUBDIRS = po
+
+if HAVE_MANPAGES
+SUBDIRS += src/man
+endif
# Some old versions of automake don't define builddir
builddir ?= .
@@ -1063,7 +1067,9 @@ endif
# TRANSLATIONS #
################
update-po:
+if HAVE_MANPAGES
$(MAKE) -C src/man update-po
+endif
$(MAKE) -C po update-po
#######################