summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJan Cholasta <jcholast@redhat.com>2012-02-26 13:24:16 -0500
committerStephen Gallagher <sgallagh@redhat.com>2012-02-26 20:34:18 -0500
commit748ba184db97b7534254f97018fa04e8aa458fae (patch)
treeb083c6a3c3bc7a0fc116af69d17e3c04627833a8 /Makefile.am
parent9e896dc45792ea7d2f267b4fbd49542d10339c63 (diff)
downloadsssd-748ba184db97b7534254f97018fa04e8aa458fae.tar.gz
sssd-748ba184db97b7534254f97018fa04e8aa458fae.tar.xz
sssd-748ba184db97b7534254f97018fa04e8aa458fae.zip
SSH: Refactor responder and client common code
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 7 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index 8ce8c64dc..a1fafcd35 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -322,6 +322,7 @@ dist_noinst_HEADERS = \
src/util/sss_krb5.h \
src/util/sss_selinux.h \
src/util/sss_utf8.h \
+ src/util/sss_ssh.h \
src/util/refcount.h \
src/util/find_uid.h \
src/util/user_info_msg.h \
@@ -391,7 +392,7 @@ dist_noinst_HEADERS = \
src/resolv/ares/ares_parse_txt_reply.h \
src/resolv/ares/ares_data.h \
src/tests/common.h \
- src/sss_client/ssh/sss_ssh.h
+ src/sss_client/ssh/sss_ssh_client.h
if HAVE_NSS
@@ -450,7 +451,9 @@ if BUILD_SUDO
libsss_util_la_SOURCES += src/db/sysdb_sudo.c
endif
if BUILD_SSH
- libsss_util_la_SOURCES += src/db/sysdb_ssh.c
+libsss_util_la_SOURCES += \
+ src/db/sysdb_ssh.c \
+ src/util/sss_ssh.c
endif
lib_LTLIBRARIES = libipa_hbac.la
@@ -648,7 +651,7 @@ endif
if BUILD_SSH
sss_ssh_authorizedkeys_SOURCES = \
src/sss_client/common.c \
- src/sss_client/ssh/sss_ssh.c \
+ src/sss_client/ssh/sss_ssh_client.c \
src/sss_client/ssh/sss_ssh_authorizedkeys.c
sss_ssh_authorizedkeys_CFLAGS = $(AM_CFLAGS)
sss_ssh_authorizedkeys_LDADD = \
@@ -656,7 +659,7 @@ sss_ssh_authorizedkeys_LDADD = \
sss_ssh_knownhostsproxy_SOURCES = \
src/sss_client/common.c \
- src/sss_client/ssh/sss_ssh.c \
+ src/sss_client/ssh/sss_ssh_client.c \
src/sss_client/ssh/sss_ssh_knownhostsproxy.c
sss_ssh_knownhostsproxy_CFLAGS = $(AM_CFLAGS)
sss_ssh_knownhostsproxy_LDADD = \