summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJakub Hrozek <jhrozek@redhat.com>2011-07-12 21:22:22 +0200
committerStephen Gallagher <sgallagh@redhat.com>2011-07-13 11:00:47 -0400
commit72e60fd4eabcfbcdbfe01e8c38b94052bc6c2067 (patch)
tree6702b1ff93ef9b3fd66ff5b921bb9732bd7f96a0 /Makefile.am
parent22d268c88f6d324b3a66846af007b06488eddae7 (diff)
downloadsssd-72e60fd4eabcfbcdbfe01e8c38b94052bc6c2067.tar.gz
sssd-72e60fd4eabcfbcdbfe01e8c38b94052bc6c2067.tar.xz
sssd-72e60fd4eabcfbcdbfe01e8c38b94052bc6c2067.zip
Fix python HBAC bindings for python <= 2.4
Several parts of the HBAC python bindings did not work with old Python versions, such as the one shipped in RHEL5. The changes include: * a compatibility wrapper around python set object * PyModule_AddIntMacro compat macro * Py_ssize_t compat definition * Do not use PyUnicode_FromFormat * several function prototypes and structures used to have "char arguments where they have "const char *" in recent versions. This caused compilation warnings this patch mitigates by using the discard_const hack on python 2.4
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 1eb2e7a7f..6829788ae 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -283,6 +283,7 @@ dist_noinst_HEADERS = \
src/util/util.h \
src/util/strtonum.h \
src/util/sss_ldap.h \
+ src/util/sss_python.h \
src/util/sss_krb5.h \
src/util/refcount.h \
src/util/find_uid.h \
@@ -1019,7 +1020,8 @@ pysss_la_LDFLAGS = \
-module
pyhbac_la_SOURCES = \
- src/python/pyhbac.c
+ src/python/pyhbac.c \
+ src/util/sss_python.c
pyhbac_la_CFLAGS = \
$(AM_CFLAGS) \
$(PYTHON_CFLAGS)