summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJakub Hrozek <jhrozek@redhat.com>2012-02-02 08:55:28 +0100
committerStephen Gallagher <sgallagh@redhat.com>2012-02-05 19:16:16 -0500
commit6e8238868a4d17030bb4f01494961d0354a953bf (patch)
tree5e7065d66e7423ef48cf5f7836fdaf54063f20d6 /Makefile.am
parent2cbdd12983eb85eddb90f64cfafb24eae5b448f4 (diff)
downloadsssd-6e8238868a4d17030bb4f01494961d0354a953bf.tar.gz
sssd-6e8238868a4d17030bb4f01494961d0354a953bf.tar.xz
sssd-6e8238868a4d17030bb4f01494961d0354a953bf.zip
AUTOFS: a command-line test client
A very simply binary that can be used to test getting data from the library via SSSD in pretty much the same way SSSD would. A required positional parameter specifies the map name and the tool would print out all the key/value pairs using _sss_getautomntent_r(). You can also specify -n to query a specific key using _sss_getautomntbyname_r().
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 27d17fa4a..f235d39b0 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -845,10 +845,21 @@ noinst_PROGRAMS = pam_test_client
if BUILD_SUDO
noinst_PROGRAMS += sss_sudo_cli
endif
+if BUILD_AUTOFS
+noinst_PROGRAMS += autofs_test_client
+endif
pam_test_client_SOURCES = src/sss_client/pam_test_client.c
pam_test_client_LDFLAGS = -lpam -lpam_misc
+if BUILD_AUTOFS
+autofs_test_client_SOURCES = src/sss_client/autofs/autofs_test_client.c \
+ src/sss_client/autofs/sss_autofs.c \
+ src/sss_client/common.c
+autofs_test_client_CFLAGS = $(AM_CFLAGS)
+autofs_test_client_LDFLAGS = -lpopt
+endif
+
####################
# Client Libraries #
####################