summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorPavel Zuna <pzuna@redhat.com>2011-10-20 13:26:18 -0400
committerStephen Gallagher <sgallagh@redhat.com>2011-12-19 11:38:35 -0500
commit6a9bdb6289bb374d203861cef16f312185725cbc (patch)
treecdd97cbecd2b4f60268bc8df55e798565f0b1626 /Makefile.am
parent1c9d778a0410cdbf516eed7d61acf214ce92067a (diff)
downloadsssd-6a9bdb6289bb374d203861cef16f312185725cbc.tar.gz
sssd-6a9bdb6289bb374d203861cef16f312185725cbc.tar.xz
sssd-6a9bdb6289bb374d203861cef16f312185725cbc.zip
Add common SIGCHLD handling for providers.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 9 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index a3eb05cc0..7ebf29f46 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -461,6 +461,7 @@ sssd_sudo_LDADD = \
endif
sssd_be_SOURCES = \
+ src/providers/child_common.c \
src/providers/data_provider_be.c \
src/providers/data_provider_fo.c \
src/providers/data_provider_opts.c \
@@ -1028,7 +1029,9 @@ krb5_child_SOURCES = \
src/providers/child_common.c \
src/providers/dp_pam_data_util.c \
src/util/user_info_msg.c \
- src/util/sss_krb5.c
+ src/util/sss_krb5.c \
+ src/util/util.c \
+ src/util/signal.c
krb5_child_CFLAGS = \
$(AM_CFLAGS) \
$(POPT_CFLAGS) \
@@ -1038,12 +1041,15 @@ krb5_child_LDADD = \
$(TALLOC_LIBS) \
$(TEVENT_LIBS) \
$(POPT_LIBS) \
+ $(DHASH_LIBS) \
$(KRB5_LIBS)
ldap_child_SOURCES = \
src/providers/ldap/ldap_child.c \
src/providers/child_common.c \
- src/util/sss_krb5.c
+ src/util/sss_krb5.c \
+ src/util/util.c \
+ src/util/signal.c
ldap_child_CFLAGS = \
$(AM_CFLAGS) \
$(POPT_CFLAGS) \
@@ -1054,6 +1060,7 @@ ldap_child_LDADD = \
$(TEVENT_LIBS) \
$(POPT_LIBS) \
$(OPENLDAP_LIBS) \
+ $(DHASH_LIBS) \
$(KRB5_LIBS)
proxy_child_SOURCES = \