summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJakub Hrozek <jhrozek@redhat.com>2011-12-25 19:14:47 +0100
committerStephen Gallagher <sgallagh@redhat.com>2012-02-05 19:16:16 -0500
commit2cbdd12983eb85eddb90f64cfafb24eae5b448f4 (patch)
tree830ed3f886ba8d8043be5f6272e9105d006b9046 /Makefile.am
parent1f1e6cbc59868f06dee3ab4b3df660fcb77ce1c8 (diff)
downloadsssd-2cbdd12983eb85eddb90f64cfafb24eae5b448f4.tar.gz
sssd-2cbdd12983eb85eddb90f64cfafb24eae5b448f4.tar.xz
sssd-2cbdd12983eb85eddb90f64cfafb24eae5b448f4.zip
AUTOFS: a client library
This is the library the autofs client is using. automounter dlopen()s the library so there is no header file, no pkgconfig file and the library is in the libsss_autofs package, not in -devel. The library provides the following interface: * _sss_setautomntent() - select the map for processing * _sss_getautomntent_r() - iterates through key/value pairs in the selected map. The key is usually the mount point, the value is mount information (server:/export) * _sss_getautomntbyname_r() - returns value for a specific key. * _sss_endautomntent() deselect a map, clean up
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am24
1 files changed, 23 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 3efa46dbc..27d17fa4a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -30,6 +30,7 @@ dbusintrospectdir = $(datarootdir)/sssd/introspect
localedir = @localedir@
nsslibdir = @nsslibdir@
pamlibdir = @pammoddir@
+autofslibdir = @appmodpath@
dbpath = @dbpath@
pluginpath = @pluginpath@
@@ -216,6 +217,7 @@ AM_CPPFLAGS = \
-DSSS_PAM_SOCKET_NAME=\"$(pipepath)/pam\" \
-DSSS_PAM_PRIV_SOCKET_NAME=\"$(pipepath)/private/pam\" \
-DSSS_SUDO_SOCKET_NAME=\"$(pipepath)/sudo\" \
+ -DSSS_AUTOFS_SOCKET_NAME=\"$(pipepath)/autofs\" \
-DLOCALEDIR=\"$(localedir)\"
EXTRA_DIST = build/config.rpath
@@ -843,6 +845,7 @@ noinst_PROGRAMS = pam_test_client
if BUILD_SUDO
noinst_PROGRAMS += sss_sudo_cli
endif
+
pam_test_client_SOURCES = src/sss_client/pam_test_client.c
pam_test_client_LDFLAGS = -lpam -lpam_misc
@@ -897,6 +900,20 @@ include_HEADERS += \
src/sss_client/sudo/sss_sudo.h
endif
+if BUILD_AUTOFS
+autofslib_LTLIBRARIES = libsss_autofs.la
+libsss_autofs_la_SOURCES = \
+ src/sss_client/common.c \
+ src/sss_client/sss_cli.h \
+ src/sss_client/autofs/sss_autofs.c \
+ src/sss_client/autofs/sss_autofs_private.h
+
+libsss_autofs_la_LDFLAGS = \
+ -module \
+ -avoid-version \
+ -Wl,--version-script,$(srcdir)/src/sss_client/autofs/sss_autofs.exports
+endif
+
dist_noinst_DATA += \
src/sss_client/sss_nss.exports \
src/sss_client/sss_pam.exports
@@ -904,6 +921,10 @@ if BUILD_SUDO
dist_noinst_DATA += src/sss_client/sss_sudo.exports
endif
+if BUILD_AUTOFS
+dist_noinst_DATA += src/sss_client/autofs/sss_autofs.exports
+endif
+
####################
# Plugin Libraries #
####################
@@ -1235,7 +1256,8 @@ installsssddirs::
$(DESTDIR)$(pidpath) \
$(DESTDIR)$(logpath) \
$(DESTDIR)$(pubconfpath) \
- $(DESTDIR)$(sudolibdir)
+ $(DESTDIR)$(sudolibdir) \
+ $(DESTDIR)$(autofslibdir)
if HAVE_DOXYGEN
docs: