summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorTimo Aaltonen <timo.aaltonen@canonical.com>2012-12-01 11:45:10 +0200
committerJakub Hrozek <jhrozek@redhat.com>2013-01-29 13:58:15 +0100
commit9c26eebe90991a1f30016f57a589d4433882fd8e (patch)
treef772bfad75b2245c9b108a43b1a0553385003516 /Makefile.am
parent24fff3b6fb04811bca0bfe8fdd4c1a851b889f70 (diff)
downloadsssd-9c26eebe90991a1f30016f57a589d4433882fd8e.tar.gz
sssd-9c26eebe90991a1f30016f57a589d4433882fd8e.tar.xz
sssd-9c26eebe90991a1f30016f57a589d4433882fd8e.zip
link sss_ssh_authorizedkeys and sss_ssh_knownhostsproxy with -lpthread
There used to be an overlinked dependency that's gone now, so to fix a build error add CLIENT_LIBS to sss_ssh_knownhostsproxy_LDFLAGS. v2: Fix sss_ssh_authorizedkeys linking as well.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index afb6622a9..e64cc091a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -663,6 +663,7 @@ sss_ssh_authorizedkeys_SOURCES = \
sss_ssh_authorizedkeys_CFLAGS = $(AM_CFLAGS)
sss_ssh_authorizedkeys_LDADD = \
libsss_util.la
+sss_ssh_authorizedkeys_LDFLAGS = $(CLIENT_LIBS)
sss_ssh_knownhostsproxy_SOURCES = \
src/sss_client/common.c \
@@ -671,6 +672,7 @@ sss_ssh_knownhostsproxy_SOURCES = \
sss_ssh_knownhostsproxy_CFLAGS = $(AM_CFLAGS)
sss_ssh_knownhostsproxy_LDADD = \
libsss_util.la
+sss_ssh_knownhostsproxy_LDFLAGS = $(CLIENT_LIBS)
endif
#################