summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJan Cholasta <jcholast@redhat.com>2012-02-27 08:04:26 -0500
committerStephen Gallagher <sgallagh@redhat.com>2012-02-27 12:16:51 -0500
commitc49e9718867874a6728bc77464f4ee8bb058832e (patch)
tree68e7c14ec850ea0facc893294c7599fc297775e9 /Makefile.am
parent293c73c93a790c08b429f461ab30ab1b809152d6 (diff)
downloadsssd-c49e9718867874a6728bc77464f4ee8bb058832e.tar.gz
sssd-c49e9718867874a6728bc77464f4ee8bb058832e.tar.xz
sssd-c49e9718867874a6728bc77464f4ee8bb058832e.zip
SSH: Replace blocking getaddrinfo call in the responder with asynchronous resolver code
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index a1fafcd35..815816585 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -533,9 +533,11 @@ if BUILD_SSH
sssd_ssh_SOURCES = \
src/responder/ssh/sshsrv.c \
src/responder/ssh/sshsrv_cmd.c \
- $(SSSD_RESPONDER_OBJ)
+ $(SSSD_RESPONDER_OBJ) \
+ $(SSSD_RESOLV_OBJ)
sssd_ssh_LDADD = \
$(SSSD_LIBS) \
+ $(CARES_LIBS) \
libsss_util.la
endif