summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJakub Hrozek <jhrozek@redhat.com>2010-10-20 17:23:11 +0200
committerStephen Gallagher <sgallagh@redhat.com>2010-12-22 13:22:27 -0500
commit6f51c802311fd81a409a26763ed45b28a3234d0d (patch)
treea4c151f83668bae7c44cbb35413e6029190c1ee7 /Makefile.am
parent2a2f642aae37e3f41cbbda162a74c2b946a4521f (diff)
downloadsssd-6f51c802311fd81a409a26763ed45b28a3234d0d.tar.gz
sssd-6f51c802311fd81a409a26763ed45b28a3234d0d.tar.xz
sssd-6f51c802311fd81a409a26763ed45b28a3234d0d.zip
Make manual pages translatable
Utilizes PO4A to extract translatable strings from Docbook XML sources and allows translators to submit ordinary .PO files. PO4A then generates translated Docbook documents that can be used to generate translated end user documentation. https://fedorahosted.org/sssd/ticket/297
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am47
1 files changed, 10 insertions, 37 deletions
diff --git a/Makefile.am b/Makefile.am
index d2cf3d07e..174c77586 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,6 +1,6 @@
DISTCHECK_CONFIGURE_FLAGS = --with-ldb-lib-dir="$$dc_install_base"/lib/ldb
-SUBDIRS = po
+SUBDIRS = po src/man
# Some old versions of automake don't define builddir
builddir ?= .
@@ -957,41 +957,15 @@ pysss_la_LDFLAGS = \
-module
endif
-############
-# MANPAGES #
-############
-
-#Special Rules:
-export SGML_CATALOG_FILES
-DOCBOOK_XSLT = http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl
-XMLLINT_FLAGS = --catalogs --postvalid --nonet --xinclude --noout
-XSLTPROC_FLAGS = --catalogs --xinclude --nonet
-
-man_MANS = \
- src/man/sss_useradd.8 src/man/sss_userdel.8 src/man/sss_usermod.8 \
- src/man/sss_groupadd.8 src/man/sss_groupdel.8 src/man/sss_groupmod.8 \
- src/man/sssd.8 src/man/sssd.conf.5 src/man/sssd-ldap.5 \
- src/man/sssd-krb5.5 src/man/sssd-ipa.5 src/man/sssd-simple.5 \
- src/man/sssd_krb5_locator_plugin.8 src/man/sss_groupshow.8 \
- src/man/pam_sss.8 src/man/sss_obfuscate.8
-EXTRA_DIST += $(man_MANS:%=%.xml) $(wildcard $(srcdir)/src/man/include/*.xml)
-
-SUFFIXES = .1.xml .1 .3.xml .3 .5.xml .5 .8.xml .8
-.1.xml.1:
- $(XMLLINT) $(XMLLINT_FLAGS) $<
- $(XSLTPROC) -o $@ $(XSLTPROC_FLAGS) $(DOCBOOK_XSLT) $<
-
-.3.xml.3:
- $(XMLLINT) $(XMLLINT_FLAGS) $<
- $(XSLTPROC) -o $@ $(XSLTPROC_FLAGS) $(DOCBOOK_XSLT) $<
-
-.5.xml.5:
- $(XMLLINT) $(XMLLINT_FLAGS) $<
- $(XSLTPROC) -o $@ $(XSLTPROC_FLAGS) $(DOCBOOK_XSLT) $<
-
-.8.xml.8:
- $(XMLLINT) $(XMLLINT_FLAGS) $<
- $(XSLTPROC) -o $@ $(XSLTPROC_FLAGS) $(DOCBOOK_XSLT) $<
+################
+# TRANSLATIONS #
+################
+update-po:
+ $(MAKE) -C src/man update-po
+ $(MAKE) -C po update-po
+
+translated-manpages:
+ $(MAKE) -C src/man translate
#######################
# Installation Extras #
@@ -1083,7 +1057,6 @@ if BUILD_PYTHON_BINDINGS
cd $(srcdir)/src/config; $(PYTHON) setup.py build --build-base $(abs_builddir)/src/config clean --all
endif
rm -Rf doc
- rm -f $(man_MANS)
CLEANFILES = *.X */*.X */*/*.X