summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorSumit Bose <sbose@redhat.com>2011-02-11 12:57:30 +0100
committerStephen Gallagher <sgallagh@redhat.com>2011-03-11 11:56:43 -0500
commit0378d4b2f764f918c4ce34e0e38f16de3d012b93 (patch)
tree153dceec6ff28ad9566be6a4d3ead09c10ff0404 /Makefile.am
parente86f86660d708853715293e8eba1ac056e0e00ab (diff)
downloadsssd-0378d4b2f764f918c4ce34e0e38f16de3d012b93.tar.gz
sssd-0378d4b2f764f918c4ce34e0e38f16de3d012b93.tar.xz
sssd-0378d4b2f764f918c4ce34e0e38f16de3d012b93.zip
Make 'make check' look nice again
With current libldb releases 'make check' will print a lot of 'unable to dlopen' messages although the test will succeed. This patch place the memberof module into a directory of its own to avoid these messages. Additionally this patch introduces TESTS_ENVIRONMENT which allows us to remove the SYSDB_TEST preprocessor definition.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 8 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index cc78d04ad..b445f9c81 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -478,6 +478,12 @@ sss_groupshow_LDADD = \
#################
# Feature Tests #
#################
+TESTS_ENVIRONMENT = LDB_MODULES_PATH=$(abs_top_builddir)/ldb_mod_test_dir
+
+ldb_mod_test_dir: memberof.la
+ mkdir -p $(builddir)/ldb_mod_test_dir
+ cp $(builddir)/.libs/memberof.so $(builddir)/ldb_mod_test_dir
+
noinst_LTLIBRARIES += \
libsss_test_common.la
@@ -494,7 +500,6 @@ sysdb_tests_SOURCES = \
src/tests/sysdb-tests.c \
$(SSSD_UTIL_OBJ)
sysdb_tests_CFLAGS = \
- -DSYSDB_TEST \
$(AM_CFLAGS) \
$(CHECK_CFLAGS)
sysdb_tests_LDADD = \
@@ -637,7 +642,6 @@ auth_tests_SOURCES = \
$(SSSD_UTIL_OBJ)
auth_tests_CFLAGS = \
$(AM_CFLAGS) \
- -DSYSDB_TEST \
$(CHECK_CFLAGS)
auth_tests_LDADD = \
$(SSSD_LIBS) \
@@ -1023,7 +1027,7 @@ docs:
@exit 1
endif
-all-local:
+all-local: ldb_mod_test_dir
if BUILD_PYTHON_BINDINGS
cd $(srcdir)/src/config; $(PYTHON) setup.py build --build-base $(abs_builddir)/src/config
endif
@@ -1055,6 +1059,7 @@ if BUILD_PYTHON_BINDINGS
cd $(srcdir)/src/config; $(PYTHON) setup.py build --build-base $(abs_builddir)/src/config clean --all
endif
rm -Rf doc
+ rm -Rf ldb_mod_test_dir
CLEANFILES = *.X */*.X */*/*.X